Adding new media to existing encounter gallery not working

Bug report template

In which Wildbook did the issue occur?
Spotting Giant Sea Bass

What operating system were you using? (eg. MacOS 10.15.3)
Windows 10

What web browser were you using? (eg. Chrome 79)
Chrome Version 84.0.4147.89

What is your role on the site? (admin, researcher, etc)

What happened?
An encounter was submitted by a user, in which the user was unable to upload one of their images. The user sent me the image separately asking if I could upload it for them. I opened the encounter and clicked “Add image to Encounter”, selected the file, and it gave me the message “Upload complete. Refresh page to see new image” (screenshot attached). However, after refreshing the page, the image did not appear. I tried this on a couple of other encounter pages (as did one of my colleagues) with the same results.

What did you expect to happen?
For the new uploaded image to appear in the encounter gallery

What are some steps we could take to reproduce the issue?
Open up an existing encounter and attempt to upload new media to the gallery.

Hi Molly,

Thanks for posting this to the forum. It appears to be related to something reported in Internet of Turtles also. We are tracking it with internal bug ticket WB-652 for reference.

We will let you know when we have a solution.


Hi @colin,

Thanks for working on this. Just checking in to see how it’s going? I tried again today and am still experiencing the problem :frowning:


Hi Molly,

We don’t have a fix in for this yet, but we have discovered that the problem
exists on other platforms too. We will keep you updated on progress
with this, thanks for your patience.

Hi Molly,

I’m working on this issue currently, starting on SGSB. Could you send me a couple of the specific images you have had trouble attaching, and possibly try uploading one again in a yourself in a private browser window to avoid caching?

I have tested with a couple images of my own with Firefox and Chrome and had success attaching them, so it must be something different in the image size, format or metadata.

Thanks. Hoping to find a fix for this quickly.

Hi Colin,

Thanks for working on this.

I gave it another try just now and initially it didn’t work with the original file I was working with, “YearlingGSB_©NathanPierce_2020-0627_NOSCtower_Shot04b_©.jpg”. However, I tried changing the filename to simplify and get rid of the © symbols (so, “YearlingGSB_NathanPierce_2020-0627_NOSCtower_Shot04b.jpg”) and that worked!

I guess I should have thought of that sooner, but I figured that wouldn’t be the issue because the other two files in this encounter that the diver originally submitted also had those symbols in their filesnames, too. Anyway, I think we should be all set now. Sorry for the trouble and I’m glad we got it resolved!


Awesome! That’s a great clue, and I’m glad you were able to complete the upload you needed. I’ll do some research and see if we can make some changes to better accept special characters in image filenames.

1 Like

Hi Colin, We’re having a similar issue with the Bull ray wild book. When I set my browser (chrome) to private it worked. But will we have to do this from now onwards for all uploads? or is it a temporary issue? Thanks a milion.

1 Like

Hi, @joanagcl!
I just deployed an update to manta matcher last week that included the fix for issue WB-652. This should be working on manta matcher.

When you say “similar” issue, could I ask you to elaborate on exactly what is happening for you?

If you have links to encounters to which you’re trying to add new images, that would be very helpful.

It’s possible that the reason that it works in private mode but not “normal” mode on your browser is because it is caching an earlier version of Could I trouble you to clear the cache on your browser and try again not in private/incognito mode?

Many thanks,