"Argument errors" message showing up when confirming a match

In which Wildbook did the issue occur? ACW

What operating system were you using? Win 10

What web browser were you using? latest chrome

What is your role on the site? admin & researcher

What happened?
When clicking on a match result to confirm a match with the target encounter, the system gives an “argument errors” message:
The researcher fixed this example but this is the results page where she got the screenshot below - Wildbook for Carnivores

Refreshing the page sometimes fixes it but sometimes the researcher has to re-confirm the match after the page refresh for the system to ‘accept’ the match confirmation.


Hi @ACWadmin1,

Can you please send an example of this happening? I unset the ID and tried to reproduce the error in Chrome and Firefox, but I could not reproduce it. Since the researcher got past it, I am marking this as resolved, but I am open to trying to dig deeper if there is a live example I can reproduce.


We are having the same issue in Wildbook for zebras


Can you please send a link? We need links to try to solve the issue as it appears to you.


Hi @jason - I’ve asked one of the researchers to NOT fix the issue before we give you the next link (she keeps doing that!). Will insert link(s) here when I get the next one(s).


1 Like

Here is the link for an example: Wildbook for Zebras


On that match page, can you please describe which items you clicked to get the “Argument errors” and in which browser? On a first click through, I am not reproducing it in Chrome.

Here’s an example that hasn’t been “confirmed” - you’ll see from the screenshot below that initially when trying to confirm match#2 as a match to the target, the system gave an “argument errors” message. The researcher did not refresh the page and sent the link here, but I’m not sure if you will have the same result, since leaving the page and going back in, even as another user, is effectively like a refresh?

Anyway, here’s the link and below is the screenshot: Wildbook for Carnivores


I refreshed the page several times in Chrome and Firefox (Win 10) after matching your selection choices and could not reproduce, but I have an admin-level account.

Are you able to reproduce this with a researcher-level account?

Unfortunately, no, not with this example, I think because a refresh almost always solves the issue. You might only see it if you try to confirm matches yourself until you get an example.
Also, it doesn’t seem to happen with every match confirmation, only some. Here’s another example from the researcher that she didn’t refresh and that I haven’t touched; but I suspect also won’t show the issue for the same reason as the example above:
match #2: Wildbook for Carnivores
In this case, the researcher reported that the issue arose with “pretty much all matches #2-7 & #9-10”.

Without the ability to reproduce this and with the workaround being a browser refresh, we are unlikely to look further into this as we prioritize other issues.