Bizarre problem with bulk import

What Wildbook are you working in? Whiskerbook

What is the entire URL out of the browser, exactly where the error occurred?
the Bulk Import review page

Can you describe what the issue is you’re experiencing?
Both the user and I tried uploading his images and spreadsheet - him in Whiskerbook and me, as a test, on ACW. Both attempts resulted in a bulk import review page that I’ve never seen before:

I have sent the import file to the services @ address.

Thanks for your help with this!


Thanks, Maureen. I just tested this spreadsheet in Flukebook, and got the same result. But when I tested with another import, it worked normally, which rules out something weird in Wildbook.

After testing the upload in Whiskerbook by uploading a few single encounters from the spreadsheet, it looks like the common theme is that the encounters causing this error all reference marked individuals that don’t exist in Whiskerbook. I checked against 15 of the encounters that don’t have anything in the MarkedIndividual.individualID field and those encounters don’t bring up the code block on top of the table.

Here are my recommendations:

  • MarkedIndividual.individualID should only have the names of marked individuals that already exist in Whiskerbook. Let me know if the norm is that new individuals should be created via bulk import and I can flag it as a bug.
  • Encounter.month should be a number 1-12, but most rows have numbers that don’t correspond to months like 00 or 59.
  • Encounter.locationID doesn’t reference any of the existing Location IDs in Whiskerbook. They need to be requested as new locations before they can be imported.
1 Like

Hi @Anastasia - thanks for the quick reply and eagle eyes! Of course location IDs are an issue! As is the month number. The latter is easy to fix, but for the location IDs, I’ll need to consult with this group’s to understand their needs.

I don’t think the Individual IDs are related to the import issue. ACW users have done ID’d image uploads (pre-existing ID kits) to the platform via bulk import without any issue. In fact, some of the first uploads we did were ID kits. The Marked Individual page is created from the ID’d encounter record.

Unless something has changed that I wasn’t aware of? Could you let me know? We actually give users 2 templates when they get started on the system - 1 for un-ID’d images and the other for un-ID’d images. So if they can no longer successfully bulk import ID kits, I need to know.

Thanks for catching the issues with the metadata that I missed. Duh. Sorry for that!

I’ll get back to you once I understand the location IDs needed by this team.


1 Like

I tested adding a new marked individual ID in Flukebook and I didn’t see the strange code. If you scroll down past the code block in Whiskerbook, you’ll eventually see the results table. It’s possible that it doesn’t actually impact the ability to import but that a new marked individual could trigger it to display.

This would be a bug re: Individual ID in spreadsheet causing this wacky code block to appear in the bulk import parsed table. I just tested uploading a different ID’d upload spreadsheet to ACW and got the same result.

And I believe it does impact the import because the “MarkedIndividual.individualID” column is highlighted in blue (after you scroll down past the weird code block) which, per the source file, is not an empty column. So the bulk import functionality is no longer allowing ID’d images to be uploaded, it appears.

The “Encounter.verbatimLocality” column is also blue whereas the source file has some rows with data in that field, that don’t have any special characters.

I can also see that the system doesn’t appear to like special characters in the LocationID field (replacing them with ? in the parsed import table) but I’d have to see what happens upon upload once we actually have location IDs for these set up in the system.

Lastly, I submitted the original bulk import on ACW again (hadn’t gone past the Bulk Import review page earlier) and got this error, which doesn’t change when the page is refreshed:

So something is definitely not working right here. I really appreciate the help to figure it out and fix it.


Thanks for the additional details! I’m adding this to our list of bug reports.

Just adding a quick note to say that additional testing in Whiskerbook shows that the code block still appears even when an existing individual is put in the MarkedIndividual.individualID field, but it does accept the upload and no error message appears.

Hi @ACWadmin1

The fix for this is ready. I am just waiting for a quiet moment on the server to deploy it.

Thank you,

1 Like

Thanks @jason! That’s great news. A quiet moment on the server might be tough to catch, though; ACW is pretty popular these days :joy:

@ACWadmin1 Fix deployed to ACW and Whiskerbook.


I know this was already resolved, but I wanted to update with the ticket link where we tracked this fix: Whiskerbook bulk import error when adding new marked individuals · Issue #300 · WildMeOrg/Wildbook · GitHub

1 Like