Bug when re-doing feature regions in Manta Matcher

In which Wildbook did the issue occur? Manta Matcher

What operating system were you using? (eg. MacOS 10.15.3) MacOS 10.15.6 (also happened on a PC)

What web browser were you using? (eg. Chrome 79) Chrome 88

What is your role on the site? (admin, researcher, etc) Admin

What happened? A feature region was added incorrectly, so the researcher deleted that feature region to create a new one. The new feature region only showed up as one that was matchable with the old inactivated Chris Town algorithm. We couldn’t run a search with Hotspotter or PIE. This happened once before, but in that case they deleted the other encounter and reuploaded. There seems to be an issue with creating subsequent feature regions.

You can see that the new feature region isn’t matchable with the newer algorithms in the screenshot below.

https://www.mantamatcher.org/encounters/encounter.jsp?number=21b54b5b-558d-495b-bb5d-48a6e5c10b75

Screen Shot 2021-03-04 at 11.25.55 AM

What did you expect to happen? To be able to create and match from a new feature region without having to delete and reupload an entire encounter.

What are some steps we could take to reproduce the issue? Try to create a matchable feature region with this encounter: MantaMatcher

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

1 Like

I just tried the links you provided and I am being taken to an encounter search form. Can you double check the links @AFlam ?

It was the encounter when I copied it in, but this is the encounter number: 692a2709-1ece-4064-9dde-18662202f920

Not sure what happened, but I’m able to get there with the encounter number you provided. Thanks! We’ll get looking at this

Hi @AFlam!
I was able to navigate to encounter 692a2709-1ece-4064-9dde-18662202f920 with MantaMatcher, but it looks like a different image from the one in your screenshot above (see my screenshot). In fact, it looks like the manta where the feature gets rotated 180 degrees from your other community post.
Go fish (get it?)?
-Mark

Hi, @AFlam !
Just reaching out to see whether this is still an issue.

Many thanks,
Mark

Hi! Sorry for the late response. Yes, it looks like I’ve put in the other encounter we had an issue with. I think the original encounter on this might have been deleted and reuploaded by a research assistant so she could make the match.

I just tested this on the other Thai birostris (not the original Mozambique alfredi), and it seems it’s still an issue. When I deleted the existing feature region, then made a new one, it only appeared as matchable by the old Chris Town algorithm, and there’s no option to match with Hotspotter or PIE.

So it seems it’s still an issue. We don’t delete feature regions a lot (most often when training new people), so it’s not a HUGE issue, but it’s definitely a little hassle if we need to reupload an entire encounter if we just want to create an updated feature region.

Hi, @AFlam !

I think I understand the problem now and agree with your assessment that it’s a bug created upon deletion of a candidate region.

We’re tracking the ticket internally as WB-1585. Thanks for finding it.

You’re already well aware of the (tedious if workable) workaround in the meantime.

Thanks again,
Mark

1 Like

We are having a similar issue with the Florida mantas, we are unable to access the Hostpotter or PIE algorithms.

Ola! I’ve encountered another manta with bugs around the candidate region, and I figured I’d drop it here rather than starting a new report, because this feels connected.

It’s this manta: https://www.mantamatcher.org/encounters/encounter.jsp?number=c8649e1a-269a-4433-ac1b-a97acd116008

I tried to set a candidate region (for the first time as far as I can tell). I got an error:

But the little candidate region appeared (a little box next to the photos, like it used to with the old Algorithm), but not a new larger photo that I would use to match with Hotspotter or PIE.

So I can’t match this manta, and I can’t figure out how to get a working candidate region set up (short of deleting and reuploading)

2 Likes

I am running into the same issue when trying to create a candidate region to run the Hotspotter algorithm. After I click on “Save as candidate region”, I got the same error as @AFlam.

As a result, I similarly cannot use Hotspotter to find matches.

1 Like

@FLManta we’re on it! Resolving some of this it my plan for today and tomorrow!
-Mark

Hello, @AFlam and @FLManta !
I believe that I have resolved bug with the “Error: I was unable to execute the action” issue. I was able to run hotspotter and PIE on a manual annotation.
There do still seem to be some issues with deleting candidate regions, so I’m leaving this thread open because there is more work to be done, but hopefully this unblocks you to some extent in the meantime?
Many thanks,
Mark

Thanks @MarkF! I was successfully able to create a candidate region and that bug does seems to be solved. I was still unable to “start match” to run Hotspotter or PIE algorithms. I’ve tried this by editing a previously uploaded encounter and with a new upload, but still run into the same issue.

1 Like

Hi, @FLManta !
Thanks for that. In the meantime, is it possible for you to create a manual annotation and then run matching on that?
Cheers,
Mark

Hi @MarkF,

Yes I’ve been using the visual matcher or manually adding to existing individual. We match our mantas within our own database before adding to MM anyways, but would love to be able to use the algorithm as a second method.

Thanks!