Media may be missing from encounters

In which Wildbook did the issue occur?
Spotting Giant Sea Bass

What operating system were you using? (eg. MacOS 10.15.3)
Windows 10

What web browser were you using? (eg. Chrome 79)
Chrome 86

What is your role on the site? (admin, researcher, etc)

What happened?
Over the last few months we have noticed an unusually high number of encounters submitted that are missing media (photos, video), but which clearly intended to attach media based on the comments. We are still receiving submissions with media, so we know it’s not a sweeping problem, but we are concerned that there’s some sort of frontend or backend bug that’s causing a subset of submissions to lose their media. In these instances, we always contact the submitter to see if they can email us the media, but we don’t typically get a response. So, we’re losing data.

What did you expect to happen?
All but very very few submissions should have attached media. When a user submits an encounter without media, they usually indicate as such in the comments (e.g., “we saw this giant sea bass at Casino Point, Catalina in about 50ft of water but it swam away too fast to get a picture”)

What are some steps we could take to reproduce the issue?
See a few examples of encounters where no media was attached, e.g., one, two, three
You could try doing a couple of test submissions. Also maybe review the website structure to see if anything was restructured since the WB7 rollout that would affect this?

Hi Molly,

I can see that the Encounters do not have images. Poking around on the server file system and logs, I don’t see any evidence that they ever had images.

From our side, I was able to easily upload an Encounter with two images and see them rendered:

(sorry, i only had whale images quickly available…I will delete the Encounter).

Without examples where we can confirm images were entered into the submission form, we’re not able to see if there is an issue.

Can you try to reproduce the issue by submitting data?


Thanks for looking into this, @jason.

We’ve tried uploading from our end with no issues, either. One thing we were wondering about is if people are trying to submit different file types that aren’t accepted by Wildbook. Are there certain filetypes that won’t upload? I see the submission form says jpg, png, and mp4, but I tried a gif just for fun and it actually worked.


Our officially supported formats are jpg, png, and bmp.
We also have recommendations regarding image size: no larger than 1600px in height or width. Slow connections can time out when uploading really large images.

Hi @tanyastere

OK, good to know about supported formats. Our website does also appear to accept at least mp4 and gif.

It’s possible that these submitters’ connections are just timing out. Perhaps we should provide more specific instructions on the submission page. Would you mind directing me towards which files in GitHub we’d need to edit to change the copy on the Submission page?


Hi Molly.

The text and translations for everything on that page are found in files under Wildbook/src/main/resources/bundles/ and then a two character subfolder for each language translation like ‘en’ for english and ‘es’ for spanish.

Each properties file has a list of keys set equal to the actual text you see on the site. The keys should not be changed since they are how we reference translations in the code, but anything to the right of a key can be changed. Each key and text value will look something like this:

samplingProtocol = Sampling Protocol

If these files are changed it requires a server redeploy, just like with location ID’s.

Hope this helps.

Thanks, Colin. I just made the changes so they should be ready to deploy when you get a chance.