No matchable detection

In which Wildbook did the issue occur? IoT

What operating system were you using? (eg. MacOS 10.15.3) MacOs10.11.6

What web browser were you using? (eg. Chrome 79) Chrome 87.0.4280.141 (

What is your role on the site? (admin, researcher, etc) researcher

What happened? I am trying to match individuals using the built-in algo and I am getting a “no matchable detection” in the burger menu of perfectly good quality photos.
Why is this?

What did you expect to happen? be able to search potential matches

What are some steps we could take to reproduce the issue?
try this link: https://iot.wildbook.org/encounters/encounter.jsp?number=064ca892-ff33-4769-bdae-46a032575719

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Hello,

I’ve taken a look at your image and resubmitted it using a couple different methods. The head
annotation was correctly set for matching and didn’t give an indication of why it was missed in your
upload.

I’ve manually set the head annotation for the link you provided to be eligible for matching.

It is especially interesting that the second image in the encounter was set correctly the first time.

Do you have other examples of this?

Thanks.

1 Like

Thanks Colin for having a look.
I have: Internet of Turtles

Heer the Ls only impacted:
https://iot.wildbook.org/encounters/encounter.jsp?number=9577d85c-ae55-448f-b230-c48547576620

https://iot.wildbook.org/encounters/encounter.jsp?number=e17f39c4-ce26-4e9b-b242-cc4fa0d117dc

Cheers!

Hello,

I’ve done some investigation on these encounters today, and manually set the head annotations on these images to be matchable.

For testing I downloaded and resubmitted these images, tweaked image size and filename and got expected annotation matchability each time. It looks like the two encounters were submitted in the second week of Jan 2020. We keep about a year of server logs, and just passed this window. Unfortunately due to this I can’t see what happened on the initial submission- but the problem appears to no longer be occurring. We did quite a bit of image analysis development last year and it seems this is an issue that was already ironed out.

If you see any more encounters like this I would remove the unmatchable head annotation, use the add-annotation tool from the matching menu for that image and add another head annotation which will be automatically be matchable.

I would like to mention the images in this encounter:
https://iot.wildbook.org/encounters/encounter.jsp?number=9577d85c-ae55-448f-b230-c48547576620

They are extremely small- 195x86 and 109x77 pixels. This is not very much information and it appears to have caused some unpredictable annotations, which I removed. There isn’t a minimum limit to acceptable image size but do be aware that low information images might have some odd detections.

Thanks! Hope that helps.

1 Like

Hi Colin,
Thanks for looking into this for me. I tried what you suggested with annotations but I am running up against another problem. Broken images and denied permissions.
For example:
https://iot.wildbook.org/encounters/encounter.jsp?number=e17f39c4-ce26-4e9b-b242-cc4fa0d117dc

Screen Shot 2021-02-03 at 17.00.16

And when I get the media asset I get an “Acess denied” prompt!

Hi, @E.Germanov !
I was able to reproduce the image not loading above in https://iot.wildbook.org/encounters/manualAnnotation.jsp?encounterId=e17f39c4-ce26-4e9b-b242-cc4fa0d117dc&assetId=488711.
It looks like a filename problem. I’ve filed a ticket for that bug, and we’re tracking it under the ID: WB-1455

As for the denied permissions error, I didn’t reproduce that as an admin. It looks like users with the “researcher” role, which you are, can view manualAnnotation.jsp pages. It may be the case that you’re not a collaborator with the submitter of encounter: https://iot.wildbook.org/encounters/encounter.jsp?number=e17f39c4-ce26-4e9b-b242-cc4fa0d117dc? Is that possible?

1 Like

Thanks for looking into it for me Mark. The submitter is Janis Argeswara who is my research assisatant. I am not sure how to designate her as a collaborator.
Also, a new account “UNUD” will need to be linked as a collaborator to Janis and I. This account will be helping with matching submissions that will be mostly batch uploaded. Is that possible?

Hey there!
You can set up your own collaborations through the My Account page under Administer. You can find the details here:

You can have collaborations with as many users as you need, so having one with the new account should be no issue.

Thanks,
Tanya

1 Like

Thanks Tanya,
So under “Manage Projects section”.
Do the collaborators need to do the same?

Do other Wildbooks have this feature?

Thank you!

Hi Mark,
Just adding more encounters here that have the same problem. I can “add annotation” but what I get is the broken image icon shown in the screenshot above.

https://iot.wildbook.org/encounters/manualAnnotation.jsp?encounterId=ffe5d5e9-9956-4b7b-a594-35a83f2e7d66&assetId=257798

https://iot.wildbook.org/encounters/encounter.jsp?number=19b3c766-7884-4719-9042-753000d2faec

Also, my team member @argeswaraj does not have the ability to edit a project to allow others to help with the matching after she batch uplaods.

Thanks for your help!

a few more like the above:

f88febdc-4384-412c-854e-7f8f1188ca26
64cee783-787c-4953-9d37-9bdc2da3a409
ffe5d5e9-9956-4b7b-a594-35a83f2e7d66
1d52712e-d040-4c4d-8f03-5cc324a3a67c
f21c9718-97d7-496a-ac76-2fff1f0c9f72
a3bc5b9d-ec7f-4a5d-ac84-d1bc6ffc56d3
3eb699f7-f736-4a7b-b3d3-66761aa2bdc0
19b3c766-7884-4719-9042-753000d2faec
efcb0531-5321-4aeb-884f-31c8064976a4
91d6af7b-c368-4ab8-9a83-48cbc5c71a96
0272e7b1-3b24-4ed3-b08d-d5eb8526e390
b62dcc41-89b4-4102-ab9e-52e1bd7069fc

@E.Germanov , Sorry for the delay in getting back to you,
There was a gap in our permission model that I wasn’t aware of when I made my recommendations. Now that gap has been fixed (WB-1488), and I’ll run you through it quickly.

To create a collaboration, you’ll want to go to Administer > My Accountimage
From there, you’ll scroll down to Collaborations and use the User Lookup field to search for your collaborator.


Once you’ve found the user you are looking for, click what appears in the dropdown and click Initiate.
The other user will get an invitation to collaborate. Once they accept, you will be in a collaboration.

Collaborations have two levels: view and edit. View collaborations do not change your access from what you’re used to. Granting Edit permissions will allow the other user to make edits to any of the metadata that you have.
Note that both users need to accept the collaboration and the upgrade to Edit access, and this permission can be revoked if needed.

Projects work a little differently. Projects grant people View access and allow for a user to share a subset of their data rather than the whole thing. This is great for catalog processing or working on datasets from different users. If you and a collaborator want to work together in a project, it will just provide a way to see that you have worked through all the data you intended to.