Not able to merge encounters

So after merging our ‘new id’ 1331 to the historical ID 868, the Marked individual merge tool page, shows… Eubalaena glacialis #1331.
See photo of page. Also, we would hope that the ID # would be updated to reflect #868 in the matching table. Does this not happen? ?? Is it too much to hope that all 1331, encounters would be updated to be #868?? or do we have to merge each encounter separately?

Can you let me know which browser and OS you used when you tried? @clsims Let me know which browser and OS you used, as well. I wonder if it’s a potential bug that’s browser-specific.

For the rest, I think it might be best if we got on a call together to talk through this and the Historical Data issue. I want to get Jason on the call, too. Can you give me some times that work for you and I’ll schedule a meeting time that works for everyone?

@Anastasia @jwaite, I have Chrome, Version 117.0.5938.134. Janice and I should probably have the exact same as it is govt computer. Tomorrow I can let her log on to Flukebook from my computer and see if it makes a difference.
I can meet tomorrow 9-1030, or anytime after 11:15. Friday my schedule is clear.

I’m using a slightly different version of Chrome (Version 117.0.5938.149). But I just got a new laptop and it didn’t work on either. The last laptop was probably the same version as Christy’s. I’m free the same times as Christy.

Thanks! Can you let me know which time zone you’re in?

PST (do I really need 20 characters?)

:joy: It’s a little arbitrary, but it also helps prevent random bot behavior from spamming the forums.

Thanks for meeting with us today! Based on our discussion, this is likely a bug that we need more time to research and may need to bring in other teammates to help troubleshoot. We’ve temporarily reset @jwaite’s account password while we use it to test a fix. As soon as we’re done with that, we’ll help you update your password.

@Anastasia @jwaite
Hi there, thought I would check in on the status of Janice’s merge id issue?

With the ongoing server outage the team has been focusing their efforts on getting WBIA back online, so I don’t have any updates on the merge issue yet. I’ll follow up on it once the outage is resolved.

Now that the WBIA outage is resolved, we should be able to continue investigating the bug that’s preventing @jwaite from merging individuals. I hope to have an update for you next week. Thank you for your patience.

Great - thank you.


Hi @jwaite Can you try the merge again from the match page now? It should work correctly:

Great - I will try today and let you know. Is the issue with the right whale match still being looked at?

According to Jason, somewhere in an import six belugas were merged with individuals from other species. Our recent import fix that prevents marked individuals from getting duplicate pages created should prevent this from happening in the future. But what you and Christy saw before should be resolved.

The merge link from the earlier post in this thread shows the old state (pointing at a right whale), so that will not appear to be fixed but rather if you return to the match page and try to do the merge again, you’ll correctly get same-species merging behavior.

OK - that’s great to hear. Thanks!

1 Like

Hi Anastasia,

I am trying to merge the whale here (encounter 8b1c4064; ID 1331) to the second Match on this page (ID 868):

I’ve now been waiting over 15 minutes and still have this Waiting on merge

So it seems that it is not fixed for me to merge.


Thanks for the update. I’m working with Jason to figure out what’ preventing it from loading for you.

Ok, so the good news is that we’ve figured out how to unblock you while we continue to debug this. Part of the code checks for whether a user has a project. If no project is found, then the loading bar stays put.

As a workaround, I’ve added you and @clsims to a test project with no encounters in it so that you can continue working on merges. We’ll need a little more time to keep working on the underlying issue.

Sorry for the late follow-up. I believe the underlying fix for this was implemented already. I’m going to resolve this but let us know if you see issues with this again.

I just tried this and it worked! Thanks for the fix.