Bulk Data Import - Parsed Import Table - Missing photos

What Wildbook are you working in?
Amphibian and Reptile Wildbook

Can you describe what the issue is you’re experiencing?
During Bulk Data Import, Parsed Import Table shows missing photos, but first 21 are green in Encounter.mediaAsset0. The rest 94 are red Encounter.mediaAsset0.

Missing photos(94):

  • Row: 22 Column: 0 Filename: (KOBT230620.jpg) … .

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Hi @Felix.Stumpf

Can you send your spreadsheet and a few of the photos you’re trying to import to services@wildme.org so I can investigate this further?

1 Like

Hi @Felix.Stumpf

Thanks for sending me your files!

I wasn’t able to replicate this error. I was able to complete a test import with the spreadsheet and the images you provided.

  • Have you verified that all of the photos referenced in your spreadsheet are in the folder you’re importing?
  • Have you tried your import in a different browser? If the files are correct, I’m curious if using a different browser lets you complete the upload.
1 Like

Hello Anastasia,

thank you for trying/testing it out with my data and your response.
I tried a different Browser(Chrome, Firefox) but nothing changed.
All the pictures are stored in my folder.

I think that i can’t upload more pictures to wildbook. Is it possible to delete the uploaded images from the upload server once, without removing the projects?

Thanks for checking and confirming! You shouldn’t have to delete anything; there’s no limit to how much a user can upload.

I’ll need a little more time to see if there’s anything on our side that could be contributing to this.

Can you try breaking up this import into smaller batches across multiple spreadsheets to see if that helps?

Thank you very much for your research and the suggestion!

Unfortunately, I couldn’t manage to split and upload the spreadsheet (second part).
Now it’s showing me that the photos are missing from row 12 onwards and from there all fields of ‘Encounter.mediaAsset0’ are highlighted in red.

Missing photos(82):

  • Row: 12 Column: 0 Filename: (KOBT230632.jpg)

  • Row: 13 Column: 0 Filename: (KOBT230633.jpg)

    Import Overview:

    Excel File Name: /data/upload/Felix.Stumpf/WildbookStandardFormat Tag8 Teil2.xlsx
    Excel File Successfully Found = true
    Excel Sheets in File = 2
    Excel Rows = 94
    Excel Columns = 21
    Trial Run: true

We may have to work on this in real-time with a screenshare. Can you let me know when you’re free to meet? I’ll send you an email with my calendar so we can schedule a time.

Thanks for meeting with me today! An interesting thing happened after we wrapped up our call - the test import under the researcher account finished importing all 115 images and then showed all green cells on the Parsed Import Table. :upside_down_face:

I think that page was left alone for about 10 minutes from when the photo import started until it fully completed. If you have time this weekend to try it again, I’d like for you to try these steps:

  1. When you start a new bulk import, select your image folder again (so we don’t rely on the incomplete cache from the previous upload attempt)
  2. Leave the photo upload page along until it refreshes on its own (may take up to 10 minutes to fully complete). Verify it imported 115 images.
  3. Upload your spreadsheet as usual
  4. Parsed Import Table should show all Encounter.mediaAsset0 rows in green

In the meantime, I’ll find out if there’ something on our end making photo uploads slower than usual in ARW.

1 Like

I’m glad it worked out! I also spoke with my teammates and verified ARW is functioning normally. The size and number of image files (many were 5-8 mb) as well as internet speed are going to be the biggest factor in how long the image import step takes.

Thanks again for your patience while we worked to understand the cause!

1 Like