Bulk Import data access

Hello Team

I have recently started uploading by batch to Wildbook for Leopard Sharks. When I do a batch upload, I do not seem to have permissions to do anything with the uploaded submissions. I can’t approve them or anything.

Please can you help me.

Attached is a screen shot of my batch uploads so far…

Thank you

David (drobinson username)

Hey there @drobinson, welcome to the Wildbook Community!
First thing, I want to let you know I moved your question to a separate thread. This allows us to track the posts that don’t have answers and be sure we get to everyone who asks a question.

Now to your actual question!
Once you complete a bulk import, there is not an approval process you need to go through. Your encounters are available for you to process as you normally would (in this case, using spot mapping). If you want to work through them as they were imported, you can click the link available under “Import ID” and work down the list of encounters available there.

Hope that helps!

Hi Tanya,

Unfortunately, that doesn’t answer or resolve my question

Simply adding spot patterns is not how I would usually process. I need full access to approve submissions and edit every single aspect of my uploads. At the moment I am unable to do this when they are uploaded via bulk upload.

Something has happened to my permissions settings and I need this changed to be able to process my encounters properly.

Also, where do I find the bulk uploads when I log into Wildbook?

Many thanks


The page you are showing a screenshot of is not what is used to approve encounters or make adjustments to data. I can show you how to access the encounter page, which is where you would make those changes. (I have created an account that exactly matches your permissions and performed a bulk upload, so will start from the page you have a screenshot of in your initial post)

  1. Navigate to https://leopardshark.wildbook.org/imports.jsp
  2. Click the Import ID link in the first column:
  3. This will take you to a list of the encounters in the import you created. Select from the Enc. column.

    This will take you to the encounter.

Alternatively, after you have completed a bulk import, you can access all submissions associated with your account by navigating to Encounters > View My Submissions in the navigation bar.

Through either path, you should be able to reach the encounter page, where you should be able to make edits to the data and metadata associated with the encounter, such as adding keywords, adjusting the attributes, adding observations, etc.

Hi Tanya,

When I click on the encounter I am unable to approve it or add any further information in!

Screenshot 2021-01-20 at 10.38.38|445x500

Above is ascreenshot.

For over a decade of using Wildbook (in one form or another) I have always been able to edit all aspects of the encounters I upload.

At the moment via bulk upload… I cannot.

I can see my bulk uploads via the import link you sent but not via encounters>view my submissions.

Please help.


Based on that image, it looks like you aren’t setting the submitterID to yourself. When you created the excel file, did you include the column Encounter.submitterID and populate it with your user name?

Hi Tanya,

Just my name.

Usually when encounters are submitted for my research area by myself or others for my project they are automatically assigned to me. This hasn’t been happening lately. I receive the email to notify me of the submission but then when I try to edit it states ‘I do not have permission’ and the same thing is happening. Submitters would not know to attribute an encounter to my username. In Arabia, all encounters automatically got assigned to me, can the same be done for Cape Byron please; this would eliminate all of these problems and also allow me to edit the bulk uploads.



Okay, that gave me enough information to know where to dig.
From the admin panel, you still had the roles you were supposed to. It looks like there was a sync issue between what roles you had and what roles were determining access, though. I went through and redid them, and it appears to have resolved, from what I can tell. Can you attempt to access this encounter again and see if you have edit permissions to it?

As an aside, I do strongly encourage you to set Encounter.submitterID when doing a bulk import. It allows you to assign data to yourself or to others as the primary owner, which is a best practice in a shared data platform.

Hi Tanya,

I can add the submitter ID moving forward but this was my first attempt at a batch upload. I knew that I should be able to assign the ID directly in the encounter which is why I proceeded.

I have just checked and I still cannot modify any of my encounters; screenshot below:



The locationID you added is not a valid LocationID for this site. The LocationID you need to use is Cape Byron. LocationIDs should always exactly match the option as it appears in the UI:

You should delete this import and correct the LocationID and submitterID values. That should give you access.

Hi Tanya,

I have deleted the imports and started again, but when I upload the new batch, the old photo names are sat there on the list making selecting the appropriate ones difficult; is there a way to clear all the previously uploaded photos?

Also, I’ve got the upload working (thank you) but when I assign the encounter to me ‘drobinson’ I get a ‘access denied’ message; could you look at this for me please.



Hi Tanya,

Also, how do I upload the photographer and encounter information?

The email address worked for some reason (with a 0) but I cannot get anything else to register from the spreadsheet (see attached screenshot and uploaded excel spreadsheet.

I have tried changing the x to a 0 and a 1 but the information will not upload; please help.

Thank you


Here is the spreadsheet…


Please can someone help me with my wildbook issues.

Thank you


Hi @drobinson ,
Sorry for the delay in response. We are a small team and I happened to have a vacation, so this took a minute to get to.

If you want to email me your spreadsheet, I can look at this more definitively. But based on the screenshots, I have an idea of what is likely happening.

Encounter.submitterX.emailAddress works in tandem with the other submitterX fields. The email address must point to an email address associated with an existing account or it creates a new one. If it is an existing account, the other fields are pulled from the account information.
Encounter.photographerX.emailAddress and the related photographerX fields work similarly.

I am reviewing your bulk imports now, and will try to figure out why you aren’t able to access the encounter. If you could provide the url to the encounter you’re trying to access, that would help.

Thanks and again, sorry for the delay,

Hi Tanya,

I will give that a try on my next upload; So I don’t need to change the x to anything, just make sure all the fields are filled out? I’ll have a play with it.

I can now access the encounters but I cannot ‘assign to a user’ I get an error message saying ‘Access Denied’ - could you have a look at that for me please; I want to be able to assign local encounters and my uploads to myself.

I’ll try again with the batch uploads and get back to you if I can’t make it work.

Thank you


You do need to change the x. Change the x to a 0 for the first set you want to enter.

Looking at your bulk imports, it looks like you are inconsistently setting Encounter.submitterID. This is the value you need to set to set the data owner.
Additionally, it looks like you are still setting Encounter.locationID incorrectly; you are inputting the value EastAuatralia.CapeByron . This is not a value locationID: the locationID is Cape Byron.

You need to set at least one of these correctly to have edit access to the data, based on your current roles and permissions. I recommend deleting bulk encounter a92f9210, correcting these values in your spreadsheet, then uploading it again.

You do not need to change the mediaAsset values when reuploading. The system recognizes the same mediaAsset name on the same account.

Hi Tanya,

I think I’ve changed everything that you said (but obviously I’m doing something wrong) as I still can’t get the submitter or photographer to accept.

Attached is the upload and my excel sheet.

Thank you for your help


Can you please email me the spreadsheet at services@wildme.org? I don’t see any obvious issues from the screenshot, but I’m not able to check for whitespace or datatype issues without the actual spreadsheet.


Hi Tanya,

It actually worked; even though it said it didn’t work, it seemed to come through from the spreadsheet perfectly :o)

Thank you


1 Like