Bulk Import Sharkbook

I have my images and excel spreadsheet prepared for bulk import to sharkbook, but I am unable to upload the photos. When I click “begin upload,” I see the image list appear briefly, but then get forwarded to the next page where I get the result of “0 images found.” I have tried downsizing my images and using a smaller subset of images, but still get the same result. Could someone help me to figure out how to progress?

Hi @alexandrae, welcome!

Can you email a copy of your spreadsheet and a few of your images to services at wildme dot org so I can take a look and see what’s going on?

Also, for future reference, when you submit a Support request, fill in the template that automatically populates so that it gives us more info upfront and saves us a bit of back-and-forth on questions. :slight_smile:

Thanks for sending over your files!

Your photos are good! The issue is that for the media asset field in your spreadsheet, the file name needs to include the file extension (“filename.png” or “filename.JPG”).

I’ve written a Bulk Import Cheat Sheet you can reference if something weird happens with any future bulk imports.

1 Like

Hi Anastasia,
Thank you for taking a look, and I’ve made the change! But actually, I’m not even getting to the spreadsheet upload phase of the import - the images in the first step are not registering. I have attached the very first step of the Bulk Import, where I upload the 20 photos. As soon as I hit “Begin Upload”, I then get the “0 Images Found” page I screenshotted earlier in this thread. I cannot get any of my images to upload, even before the .xlsx upload step.

Thanks for clarifying! Give me a little more time to work on this and see what’s going on.

Hi @alexandrae

I wasn’t able to reproduce your issue. I set up a test upload on my account using the images you sent over and it accepts them as valid.

I do notice that in your screenshot, there appear to be filenames with special characters (underscores). Bulk import doesn’t play nice with special characters, so your filenames should be alphanumeric.

I completely overlooked this earlier, but Encounter.genus should always start with a capital letter and Encounter.specificEpithet should always begin with a lowercase letter. So those fields in your spreadsheet should look like this:
Screenshot 2023-02-14 at 9.53.47 AM

Let me know if this doesn’t resolve your issue.

Hi Anastasia,

Thank you for the help. This does not solve my issue - I moved the folder of images to my desktop (off of an external drive) and got rid of the underscores in front of the filenames (see screenshot). Also, I changed the specific epithet - but I’m still getting the problem of the images not uploading prior to the spreadsheet. I also tried it on a PC and got the same result (0 images). Do you have any other suggestions?

That’s super strange! Let me do some more research and I’ll get back to you.

Hi @alexandrae

When you moved the folder to your desktop, is it a single folder with just your images in it like in your zipped file? Or are the images in a folder that’s within another folder?

Ideally, the path should be something like Desktop > Folder name > List of images

If it’s more like Desktop > Folder name > Another folder name > List of images then that could be what’s causing the photos to not appear.

I’ve added a link to the relevant timestamp in our bulk import training video for a visual reference if my description doesn’t make sense.

Hi Anastasia,
I have it as a single folder with images on the desktop. That path is correct - it is not a nested folder. When I hit “begin upload” I briefly see the images starting to upload (with loading bars next to the images), and then it quickly forwards onto the next page with the “0 images” result. I had a coworker attempt this on their computer as well, with the same result. Thank you for your patience, and I’m hoping that you might have other suggestions!
Thanks again,

1 Like

Thanks for your patience. I added a few new roles to your account that I think may have been preventing you from uploading images. Apparently, Sharkbook is the outlier in having some non-standard account setup quirks which we’ve just learned the hard way. :sweat_smile:

Let me know if that gets you un-stuck!

1 Like

Thanks so much - that’s promising, but I’m still having the same result. I’m forwarded to the next page that says 0 image matches. I just tried in multiple browsers!

I’ve added this to our list of bug reports because I’m not sure what else could be preventing you from making bulk imports. You’re doing everything right.

I tweaked your role settings one more time. If this last combination or permissions doesn’t work, then we’ll leave it for the devs to investigate further.

1 Like

Thanks for your help! Unfortunately I’m still getting the same result. Please do let me know if you head back from the devs, and thanks for the help.

1 Like

To save some time, I’ve uploaded this import for you. It should appear under Encounters > View my submissions in the Sharkbook menu. We weren’t able to replicate the issue you were seeing.

The next time you want to do a bulk import, can you let me know and we can do a Zoom call to walk through it in real time?

Hi Anastasia,
Thanks for uploading the images! That was a small subset of the data (which was great to play around with and see the matching potential, so thank you), but I’m hoping to batch upload a larger dataset of ~2000 images. If you’re able to zoom to check out the import process on my end, that would be great.

Sure! FYI, we can only import a max of 1000 encounters at a time. Until we sort out where the hiccups are, let’s try again with another small set of encounters. Larger bulk imports of 1000 can take a few hours to a few days complete detection and identification.

I’ll send you an email soon to coordinate.

Thanks for meeting with me last week! We walked through the bulk import steps with Chrome’s Console Log open to capture what errors it flagged when the image import failed:

Mixed content: The page at 'https://www.sharkbook.ai/importphotos.jsp' 
was loaded over HTTPS, but requested an insecure 
XMLHttpRequest endpoint 'http://www.sharkbook.ai/accessDenied.jsp'.
This request has been blocked; the content must be served over HTTPS.

I hope to have an update on this by the end of the week.

1 Like

Hi @alexandrae

This problem is going to take longer to debug than we anticipated; I’m so sorry! I’ll let you know when we have an update. Thanks for being patient.

Hi @alexandrae

Thanks so much for being patient with us!

Apparently Sharkbook was preventing any users without the “admin” role from uploading bulk imports. We’ve corrected this and now anyone with the “researcher” role should be able to import their images without issue.

1 Like