Photo not uploading

We haven’t heard back from you in a while, so I’m closing this request. If you still need help, let us know.

Thank you for your email. When I upload photos the photos are uploaded entirely but it is not shown on the photo preview page. My photo is of the camera trap in jpeg form. Here I am sharing my xlxs file and one of the photos I used for uploading. I have attached in email

Please check your email at

Thanks for great screenshots! I looked at your spreadsheet and noticed that the file extension is missing from your photos. Using the camera trap image you attached as an example, It should appear in the spreadsheet as 2250185.JPG and not just 2250185.

Additionally, you’ll need to match the full filename exactly. In your photo upload screenshot I see 1040298.JPG and 1040299.jpg so that means when you put them in your sheet, you need to include the capital letters in JPG for the files that have them capitalized and the lowercase jpg for the files that have them in lowercase.

The following points don’t relate to the photos not appearing, but I’m pointing these out because it will cause other issues with your bulk import if they’re not corrected.

Encounter.locationID must be paired with Encounter.verbatimLocality. The Location ID field needs to match one of the locations in the dropdown menu of your Wildbook:

For any fields without data, it’s best to delete them from your spreadsheet before you upload it. Occasionally, the system will detect empty fields and proceed to ignore the data that appears in other similar fields. We recommend cleaning up your spreadsheet of any unused fields.

I recently made a Bulk Import Cheat Sheet that covers some of the most common issues that we see with bulk imports. Updates will be added as we improve our documentation.

Thank you for your kind reply. I changed the spreadsheet following your guidance, but the photos are still uploaded but not seen in the record. Furthermore, I could not find the location ID for Nepal in the encounter location in the dropdown menu of your Wildbook.

Can you post the URL to your bulk import so I can investigate further?

I’ll work on adding Nepal as a new location in Whiskerbook, but it may take a few days to complete.

Quick update to share that I’ve added Nepal to Whiskerbook’s list of available locations.

This is URL where I upload the photos
Whiskerbook | Login?

I’m sorry for the confusion. I thought you were referring to a bulk upload that was already submitted, which is why I asked for the URL as I couldn’t find it in the logs.

Give me a little more time to look into this and I’ll follow up here when I have more info.

Hi @Nasad

I wasn’t able to replicate the issue with just the sample image you sent over in your email. I suspect that for some reason, the preview just wasn’t loading your images even if they imported normally. Can you try completing your submission and let me know if you see any errors with your encounters?

We haven’t heard back from you in a while, so I’m closing this request. If you still need help, let us know.

Hi @Nasad

I’m reopening this because we’ve received similar reports of this happening in Sharkbook, too.

Hi @Nasad

This problem is going to take longer to debug than we anticipated; I’m so sorry! I’ll let you know when we have an update.

Hi @Nasad

Thanks so much for hanging in there!

Apparently Whiskerbook was preventing any users without the “admin” role from uploading bulk imports. We’ve corrected this and now anyone with the “researcher” role should be able to import their images without issue.

Thank you
The problem of not uploading photos is solved. Now the new issue is the analysis took a long time and is still not complete. How can I get the result about individual identification? How can I received the photo and result with matching information

Hi @Nasad

It looks like this encounter from your upload has a broken image and I suspect that’s what’s preventing detection from completing (media asset 20181111.JPG in your spreadsheet): Whiskerbook | Login

I need a little more time to resolve that.

As an aside, I wanted to let you know to include your Whiskerbook username in the Encounter.submitterID field of future imports. Otherwise, your imported encounters aren’t assigned to you and you won’t be able to edit them. I can update these for you manually because it’s a small set of encounters.

OK, it looks like the best course of action for this is to upload this encounter manually by going to Submit > Report an encounter in the navigation menu. Until then, you should be able to delete the image (see below) and then the numbers should line up to allow you to start identification.

Thank you, After checking the image and uploading them again the status went 100% complete but the new issue is when I click to send to identification, it says there is an error.

Thanks for the update. I’m investigating a similar identification error in a different Wildbook and will follow up when I find out more.

I think this may have just been Whiskerbook being fussy. I just attempted to start identification on your import, and it kicked off the matching process without the error.