Delayed display in candidate annotation

In which Wildbook did the issue occur? zebra codex

What operating system were you using? (eg. MacOS 10.15.3)

What web browser were you using? (eg. Chrome 79)
microsoft edge

What is your role on the site? (admin, researcher, etc)
What happened?
No images in candidate annotations
What did you expect to happen?

What are some steps we could take to reproduce the issue?
Match results for sighting 976b8c1e-c6af-4e13-a9de-0c61e1a698ea • Zebra Codex (

If this is a bulk import report, send the spreadsheet to with the email subject line matching your bug report

HI @Rosemary

I can see images for the match candidates load right away in Edge. Are you able to see them whe you try a different browser?

The sighting on this link is a duplicate with the one in screen shot and yet it gives no match. Which is
LWC0002. Have tried in both edge and chrome.

My expectation was since one photo has an ID; the one should just match.

This has worked out but after a long which is unusual.

Thanks for the example. We’ll need more time to poke around Codex to see what’s going on.

We didn’t see anything unusual in Codex, but we’ve restarted celery as a precaution. Let me know if you don’t see any improvement.