Does IOT use hotspoteter

What Wildbook are you working in? IOT

What is the entire URL out of the browser, exactly where the error occurred? N/A

Can you describe what the issue is you’re experiencing? General Q

Can you provide steps on how to reproduce what you’re experiencing? N/A

Hi there, I have some general Q’s about IOT.

  1. Which algo does it use? Is it hotspotter? I found this but did not see anything about IOT
  1. Is it normal that the matches take so long? Various members of my team have tried in on various machines and I from various different networks from both Indonesia and the US and it can take over 20 minutes or more for a match to process. I often quit the process losing patience. Are we doing something wrong?

Thank you for your help.
Ellie

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Hi Ellie,

Yes, IOT uses Hotspotter and a suite of other computer vision tools used to isolate and orient the identifiable information.

Matches can take a while for several reasons. If you are starting multiple jobs at once, or there are many other users on the platform the queue for image analysis can delay results.

The other big factor is matching set size. If you are matching against many locations with many individuals and images, it can take longer. Right now looking at the queue for the last couple days I see blocks of ID jobs around 2-3 minutes, and blocks around 12-15 minutes. My guess would be that there is a big difference in the matching set size between those two user’s work.

If you send me an encounter you are working with I can take a peek at the candidate size and turn around time, but there likely won’t be any changes to make. I’d suggest starting several jobs at once and coming back to them later for results if the wait times are extended.

Thanks.

Thanks so much Colin. Okay, I was worried that starting a few jobs at a time was actually making it slower!

Here is an example: Internet of Turtles

Thank you!

Hi Colin,
So I tried several as you suggested today by setting up 5 matches to work in the background. I set up them up this morning and over 12 hours later I am just getting an “attempting to fetch results” notification.
Here are the links the task numbers if that helps:

https://iot.wildbook.org/iaResults.jsp?taskId=740f204f-6bad-4527-8c3e-6a70e42625f9&projectIdPrefix=INXXX0000YY

Task 6ab7c564-4267-4dba-b33a-0438a9c070dc

https://iot.wildbook.org/iaResults.jsp?taskId=adeb883c-0f0e-4f22-9f8d-2452869d86a6&projectIdPrefix=INXXX0000YY

Task bae5214f-35b0-4ab9-b140-4ff4022dceaf

https://iot.wildbook.org/iaResults.jsp?taskId=c36cbee2-408c-4994-90fb-b9335e8d160e&projectIdPrefix=INXXX0000YY

Task 9f9e50bd-99f3-400a-86f1-152468987678

https://iot.wildbook.org/iaResults.jsp?taskId=4eed4f57-028b-44b0-a996-2e3d0f85836c&projectIdPrefix=INXXX0000YY

Task dc8cbd75-7197-421d-b4e1-23ca81c3aed8

Running MacOS 10.14.6 and Chrome Version 94.0.4606.6

Thanks for any insight you might be able to provide.

Hi, @E.Germanov !
When I click on all of those links, I see either “no matches found” or a list of match candidates. Maybe the 13th hour was the charm?

Hi Mark,

I kept it running overnight and nothing changes on my end. Here is what it looks like:

If I click on the task link it gives me a long string of code:

The usual table of 12 matches or not di dnot appear for any of the 5 matches I was attempting to run.

Thanks for your help!

Okay weirdly when I tried clicking on the links that I posted here it did work… I wounder why it never updated on my screen?

Except for this one:
https://iot.wildbook.org/iaResults.jsp?taskId=3e4bb9da-e6c1-4ff7-b985-e60f01ca94ee
" there was an error with task 1e6a0de7-7d79-416e-a0c5-99daed90d7e7: unknown error"

and another:
https://iot.wildbook.org/iaResults.jsp?taskId=c57a901e-2bc0-4aed-8249-c3ffec3c870f

In regard to the processing time, it was likely taking a while and the page timed out, either on our server or your browser. The results page will indeed cease asking for results after 15 minutes so there is not a left open connection. My guess would be that if you closed the tab and came back to the results later through the menu in the corner of each image on the encounter page, it would shown as complete much earlier.

I looked again at the image analysis job history and see most jobs completing in around 2.5 minutes, with a handful of exceptions at >10 minutes. The time it takes for image analysis to transmit that result back to the browser is tiny.

If your jobs are taking a long time and the page is timing out, I would try being more specific with the location ID’s selected to match against. The results pages you linked show a matching set not limited by location- and this is a huge amount of data. The results pages quote around 26,000 possible candidates for a left side viewpoint world over.

Thanks.

That makes sense Colin.
I am trying what you suggest by narrowing things down to Indonesia. Now I am getting these
errors:

“there was an error with task 51ec831b-0769-413f-8ec0-2e87fb36c103: unknown error

A few sightings where it is happening and it does not seem to matter whether or not a project is assigned.

https://iot.wildbook.org/iaResults.jsp?taskId=743cc201-1c6f-4bb7-ad6e-f7b5d4ce88e4

https://iot.wildbook.org/iaResults.jsp?taskId=55313a1e-962d-4850-b43c-f58321dd2459

https://iot.wildbook.org/iaResults.jsp?taskId=22569687-7ef4-4aeb-b503-7c82f64c555f

https://iot.wildbook.org/iaResults.jsp?taskId=ed2cb038-7634-4033-bfbe-6616a8490c37

https://iot.wildbook.org/iaResults.jsp?taskId=ee0db39d-b1e3-4931-9373-e0dacd6d2f5c

And ones where there was NO error (and relatively fast results):

https://iot.wildbook.org/iaResults.jsp?taskId=848f568f-2fc3-4980-9d62-2297de2b1208
https://iot.wildbook.org/iaResults.jsp?taskId=39c9449d-1333-4894-bb24-3597b87b573d
https://iot.wildbook.org/iaResults.jsp?taskId=10ad89b3-b353-4416-be37-19cb7037297e

I hope this helps resolve the issues?

Thank you for your help!
Ellie

Hello,

I’ve found the problem here. The tasks with errors were due to manual annotation on the image
where turtle_green was used instead of turtle_green+head. Wildbook treated these as a body
annotations, which are not eligible for identification.

There was a config bug on the server side where we allowed jobs to be started for these, which subsequently failed. I’ve corrected the config, and the ‘start a new match’ for these annotations should not appear to be an option anymore.

To run ID on these images a new annotation will need to be added with the appropriate class, and the old one removed.

Thanks!

1 Like

@colin , thanks for this!
@E.Germanov tagging you for faster turnaround.
Thanks,
Mark

Thank you both very much for looking into this. @colin @MarkF

I tried as you suggested (chang annotations to include “+head”) and I am still getting errors:

“unknown error”
https://iot.wildbook.org/encounters/encounter.jsp?number=476aa114-37db-4209-923b-27d44e8c4774
https://iot.wildbook.org/iaResults.jsp?taskId=9149d202-c3ee-4844-9bb8-5bec0ea80aba

“error initiating IA job”
https://iot.wildbook.org/encounters/encounter.jsp?number=0272e7b1-3b24-4ed3-b08d-d5eb8526e390
https://iot.wildbook.org/iaResults.jsp?taskId=338c48f5-e797-47ec-a1e6-e71d18f1f9da

“error initiating IA job”
https://iot.wildbook.org/encounters/encounter.jsp?number=22d0898f-7e68-4376-adda-e7264d03c821
https://iot.wildbook.org/iaResults.jsp?taskId=45408567-cd81-47c0-902e-0a9c75850919

“unknown error”
https://iot.wildbook.org/encounters/encounter.jsp?number=9e1b1c59-192e-4c8a-8fea-4143bdc94221
https://iot.wildbook.org/iaResults.jsp?taskId=4580a664-d323-404c-a78e-5578d73d36a6
“error initiating IA job”
https://iot.wildbook.org/encounters/encounter.jsp?number=bc902333-6bd1-47cf-9cd0-64047fc8eaec
https://iot.wildbook.org/iaResults.jsp?taskId=a15b7c3f-21dd-4490-8ee7-e61d2051dc1e

I appreciate your help trying to figure out what we are not doing quite right.
Ellie

Hi, @E.Germanov and @colin !

There’s a new ticket for this; WB-1850. One of us will follow up here when it gets resolved!
Thanks,
Mark

Hi @E.Germanov,

It appears this data was imported with an inactive location ID: Indonesia - Nusa Penida. The verbatim
location text can be anything, but the location ID field must be part of a list set by Wild Me in the database. When I ran a couple of these against just Indonesia data they completed successfully.

You can see the location ID’s we have active for Indonesia in the dropdown menu within the single encounter submission form. If there are a few additions to the Indonesia subcategory you would like to see, please advise us and we can add them. At that point they will be active for a photo ID matching set target.

Thanks!

1 Like

Hey, @E.Germanov !
Just following up here. Looks like Colin is hoping for Indonesia subcategory additions?
Thanks,
Mark