HTTP Status 500? Internal Server Error for Whale Sharks

What Wildbook are you working in? Wildbook for Whale Sharks

What is the entire URL out of the browser, exactly where the error occurred? Wildbook for Whale Sharks

Can you describe what the issue is you’re experiencing? When I send an encounter report, I get an error - HTTP Status 500? Internal server error.

I was uploading whale shark pictures as I have been doing lately, and when I tried to upload an encounter a ‘HTTP Status 500? Internal Server Error’ page came up. I tried to change the whale shark picture, and the same thing happened (even without a picture it also happened). I tried switching from Google Chrome to Firefox, and the same thing happened. I switched from WiFi to cellular data, and the same problem appears. Meanwhile, yesterday I was able to upload several whale shark encounters.

Can you provide steps on how to reproduce what you’re experiencing?

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Hi, @Bernat18m !
I was able to reproduce your error, and we’re tracking the issue internally as WB-1684.

Thank you for posting this!
-Mark

1 Like

Hi @Bernat18m,

While we’re still working on a fix for the deeper bug, I wanted to let you know that Encounter submission to whaleshark.org was restored last week. So while the bug exists, it isn’t blocking new data from coming in.

Thanks,
Jason

Hi, @Bernat18m !
We believe the deeper bug has been fixed now as well. Could I trouble you to confirm that this has been resolved?

Hello @MarkF and @jason!

It looked that it was fixed, as I managed to submit some new encounters, but a couple of hours ago I tried to submit a new encounter and I got the same error again. I tried to try it again now, and still same errors occurs.

Thanks,
Bernat

Hi @Bernat18m,

We made a SQL change to the database as part of a deeper fix to the problem and needed to restart Wildbook to let our software catch up.

It has been restarted, and I see data submission working again.

Can you please give it a try?

Thanks,
Jason

Hi @jason

It works perfectly now and I have been submitting encounters again this morning. Let’s hope it continues like that.

Thanks,
Bernat

1 Like