Identification results of bulkimport do not load


I have a problem because the identification results of several bulkimport in Flukebook do not load, I launched the identification last week and these are relatively “small” bulkimports (minimum 87 and maximum 300) so normally they should all have had time to search for the match but when I want to look at the results this window loads indefinitely (1) or I get an error message (2)

However, surprisingly the identification results of the first bulkimport I posted are displayed correctly but the 4 others do not load.

Do you have a solution or should we just wait that the servers are less overloaded ?

Thank you in advance

Here is the link to one of the pages that does not appear:

It definitely shouldn’t take a week for the ID to complete. Let me find out what happened here. Can you also email your spreadsheets for the imports that are stuck?

So, apparently the identification for pilot whales has been unblocked today, but my colleague Louise still has the same problem for sperm whales so she will send you her spreadsheets by mail. Thanks for your help


I have a similar issue with this bulk import: Flukebook | Login

Below are some screenshots of the various messages I got:


I launched the identification process last week and for most of the encounters, I think it worked because it displayed that the algorithm finished the 8th of March at 02:42 am for instance but nothing appeared. At first, I thought I just had to wait for the photos to be loaded but it never displayed any of the photos for the encounter, even after hours waiting for it.



I don’t know if it’s going to keep loading or if I need to correct something and then, relaunch the identification process.

This time, I took care of the format of my pictures so they are all in jpg. However, it was the first time that I tried to put all the photos of the same individual taken in a row (burst of photos) on the same raw under Encounter.mediaAsset0, 1, 2, etc. So maybe it could be one of the reason to explain why it did not work. I sent to you my excel linked to this bulk import.

Moreover, I figured that one of the algorithm was never displaying correct results so I would like to disactivate it if it’s possible (and this way maybe it would shorten the waiting time). It’s the PIE v2 (Pose Invariant Embeddings).

Thanks in advance for your answer,
Best regards,

Thanks for sending me your spreadsheets, @lsimon! They look good to me.

PIE is actually the fastest and most accurate of the Flukebook algorithms, so that’s the algorithm you’ll most likely want to run on your images.

I’ve gone through some of the encounters on your import and only see CurvRank results displayed, which usually means they were manually run. I’m not able to replicate what you’ve shared in the screenshots since it looks like you may have re-ran detection after posting this.

Edited to add: PIE may actually appear to be backlogged because now PIE results are appearing on encounters further down the import list. Let me know if you’re still not seeing match results appear after a few hours.

Hi @Anastasia ! :slight_smile:

Unfortunately, it’s still displaying the same window as yesterday and the photos are never loaded even though, apparently, the identification has been processed. Another weird thing is that when I’m going on the “match results by class” page, I see the 12 numbers (but no photos) appearing for two second or so and then disappear to leave an empty and blank page like below:

As you suggested the other time, I did the detection process manually for the photographs for which the detection didn’t work automatically (blank case in the “match results by class” section).

I didn’t re-run the detection/identification since I’ve started this discussion, actually not even within the last week so I don’t understand…

I don’t know what to do at this point.

Anyway, thanks a lot for your help,

PS: Little update: it works for my third bulk import but still not for the second one. I will see in the next days and keep you update !

1 Like

I’m sorry about the confusion. I had edited my reply because the matches I opened started appearing for me after I responded. Can you let me know which browser and operating system you’re using?

Hello Anastasia,
@lsimon and I still need your help. Indeed, the error messages have been coming back since the beginning of the week and are completely blocking us in our progress. We have already tried to send our bulkimports to the identification but the error message keeps appearing instead of the results.
Can you help us? Thank you in advance !

Hi @rebeca

We did have some server maintenance happen for Flukebook at the beginning of this week that affected identification:

Can you link me to the bulk imports that you’re having trouble with and email the spreadsheets that go with them?