Inspect goes to WBIA site not inspection results page

What Wildbook are you working in? ACW

What is the entire URL out of the browser, exactly where the error occurred?
Sighting: Wildbook for Carnivores | Login
Encounter: Wildbook for Carnivores | Login
Match result: Wildbook for Carnivores
Inspection on match #11:

Can you describe what the issue is you’re experiencing?
A user has reported to me on several occasions recently, with the above reported this past weekend, that in some cases, when she tries to “inspect” match results, she gets sent to the WBIA site - she sent this screenshot:

Additional examples are from matches run prior to Sept 1 which have since been cleared from the database and so no point in sending you those URL examples but I can if you want.

I haven’t been able to reproduce the same issue when I click through to the same inspect results but it’s happened several times for her now and so it would be good to understand the cause, if anyone has any ideas.

She’s found a workaround which is to close the tab and re-open as many times as needed until the correct “inspect” page opens. It can take several tries before this corrects.

She says it isn’t on all matches in the same set but can happen on up to 3 out of 12 match results in a single set.

She’s using Win10 & the latest version of Chrome.


I went through with Chrome, Firefox, and Brave while logged in and logged out and could not reproduce.

I looked at the code on our side, and the URL gets built in only one place of code, and if it were malformed, we get an ugly error message like this:

So the redirect to the base URL is a mystery. I am asking @parham to weigh in on whether WBIA might redirect to its base URL for another error/reason.

Hi @ACWadmin1

We reviewed the separately sent video of the issue. There’s another clue in that WBIA’s landing page, when it loads, is mangled with missing CSS. This suggests it’s not WBIA or Wildbook (at least not entirely) dictating this behavior and could be some aspect of a browser plugin or Internet filter happening.

Can your user please try to reproduce this with Firefox or another browser to rule out (or in) a browser plugin?


Hi @jason - I’ve sent her a note to ask her to re-run in another browser. Will get back to you with the answer. thanks!

1 Like

Hi @jason - update on this. The user tried a different browser, Firefox, on the same laptop and then also tried with her partner’s laptop. Got the same result so that rules out a browser plugin issue. I asked her to run a virus scan on her system and that didn’t change this result either. So she’s going to try to find a tech expert to help but for now, we’re stumped.

The challenge for us is, when she gets WBIA instead of the inspect results expected, if she closes it and clicks on inspect again, often she then gets the correct inspect results, although sometimes it takes a few iterations before she gets the correct inspect results. So when we get the link and click on it, it’s at least the 2nd click and so we might not see what she sees because she only sees it on the first “inspect” click.

The other challenge is that this doesn’t occur with all “inspect” clicks, not even all within the same set of match results. So hard for us to find an example.

When you suggested the possibility of an internet filter being the cause, can you please elaborate on what you mean? And any other ideas anyone might have would be much appreciated.


Internet providers and VPNs can also enforce their own blocking/filtering software. However, I think this will go away when the related Hotspotter fix under SAGE-473 is deployed. The user should not be going to this page anyway.

More on that soon.


1 Like