Is background masking in place for lynx on Whiskerbook?

What Wildbook are you working in? Whiskerbook

A user is reporting frequent examples of where the background is showing as “hotspotted” on the Inspect image comparison, per these examples:

I know background subtraction isn’t perfect but I thought I should check in to confirm, or not, whether background subtraction is actually being applied in Whiskerbook (and Wild North, for that matter), specifically to lynxes.


1 Like

Good question. Can you also share examples URLs where you see this happening while I find out more?

1 Like

It looks like spatial verification was turned off for Lynx lynx. It has been turned on now. Re-running the match should give better results now.

Was this just happening to Lynx lynx or to other lynx species as well?

1 Like

Wowwww, THANKS @Anastasia and @ACWadmin1 !!

This is really a game changer :slight_smile:

A random example :

Before (it was one of the best working ones, that I kept for a presentation) :

After :

Thank you very much for this huge improvement!

(If you have other magic tricks to activate, please do not hesitate :grin: :innocent:)


Happy to help! I’m not sure why it was turned off, it never should have been. If you notice anything weird like that again, definitely let us know.


@ACWadmin1 @Lucas I just want to verify if this was happening with other species in Whiskerbook before I resolve this topic.

Hi @Anastasia :slight_smile:

I’m sorry but I only have lynx lynx pictures, the only ones we have in France, I don’t see any other species on whiskerbook !!

1 Like

Sounds good! If it was happening to any other species, I’d make sure that we had their spatial verification turned on as well.

1 Like

Just so you know, I checked and there is the same issue in wildbook for iberian lynx (, at least for the species “lynx lynx”.

I am not a user of this wildbook now that we are on Whiskerbook, but if there are active users on this wildbook it may be a huge improvement for them to enable the background masking :slight_smile:

Examples :

1 Like

Hi @Lucas

Spatial verification is turned on for all species now. I tried re-running the link to show the new inspection map, but I’ve been getting an unknown error every time I’ve run the match, even after deleting the annotation and adding it again. I’ll need more time to verify the update.

1 Like

Ok, it’s working much better now:

1 Like

Nice, thanks @Anastasia !! :slight_smile:

1 Like