Same annotations in different places depending on view (related to odd media asset size possibly?)

What Wildbook are you working in? ACW

What is the entire URL out of the browser, exactly where the error occurred?
See URLs listed below

Can you describe what the issue is you’re experiencing?

Logged in as researcher and went to this encounter page: Wildbook for Carnivores | Login
Clicked on “Add annotation” to get a better view of the individual annotations: Wildbook for Carnivores | Login
Here, the annotations display very differently than on the thumbnail in the encounter gallery

How do I know which annotation display is correct? Hopefully it’s the Add Annotations page display bec that’s where changes to annotations are made based on what’s displayed but it’s confusing to see different positions of the same annotations in different places in the system.

Note: we tried to get another view of the annotation placement by copying the Occurrence ID for the original encounter record > Encounters > View Unapproved Encounters > applied Occurrence ID as filter “Census_08-09_2.CHEETAH_Original_5_ShaynaBarby” > clicked on tab “Matching Images/Videos” and no results displayed:

Related issue while logged in to ACW as researcher.

Encounters > My Submissions > After list populates, select “Matching Images/Videos”. This appears to bring up all of my submissions in a gallery format with annotations displayed. This is GREAT bec the hamburger allows for Add/delete annotations.

This researcher has been running into many multi-animal images where the annotation(s) need to be fixed. Unfortunately, because her focus right now is to run matching for all ID’d individuals, she’s only seeing the annotation issues when she’s on the match results page. And since it’s not possible to go to the proposed match encounter in a different window, when she goes to view and/or fix any annotation issues, she leaves the match results page. To get back to where she was with matching after sometimes a long process of adding and deleting annotations, is difficult and frustrating.

So she’d like to use this “Matching Images/Videos” page for “My submissions” to review all annotations and fix there, when/if needed BEFORE she starts any matching. She has found a large proportion of the multi-animal images of this species to have poorly placed annotations + missed annotations. So she now wants to be able to review and fix all annotations as her first step with a new dataset. There isn’t much point in doing that with her current census data but when we load the next census ('14-15), she’d like to proceed that way.

To that end, how accurately displayed are the annotations on this gallery page (“My Submissions” > “Matching Images/Video” tab)? Would it be recommended to always click through to the Add annotations view to see the most accurate reflection of the position of the annotation? If not, where is the most reliable view of the annotation placement?


Hi Maureen,

The Encounter page and the Matching Images/Video pages use exactly the same code underneath, so they should be relatively identical representations of exactly where the annotations appear.

I can definitely see the bug you indicate with the manual annotation tool. While it is displaying the other annotations incorrectly, it should still allow correct mapping of a new annotation as a workaround while we fix this bug: WB-1392.

Thanks for reporting this.


That’s all I needed to know. Thanks Jason!

Hi @jason - just a quick addendum to this issue: we have seen several instances where the annotation on the image in the encounter gallery is also skewed. It’s always where the image appears to be an irregular shape - either portrait-like or landscape. I just found another one so thought I’d pass the link and info along:


Thanks! Adding this information to the ticket, and we’ve got the work to fix this in progress (not that that means anything timeline wise :sweat_smile: )


Hello, @ACWadmin1 !

I believe that there are at least two separate issues here. One is with manualAnnotation.jsp.
The problem there was (at least) that the new height/old height =scale ratio was also being applied to width, when that should have been its own widthScale.

I believe that I have fixed that. The bounding boxes here:

resemble those here:
quite well now. Could I trouble you or the researcher to confirm that those are working better now?

As for:

“we have seen several instances where the annotation on the image in the encounter gallery is also skewed. It’s always where the image appears to be an irregular shape - either portrait-like or landscape. I just found another one so thought I’d pass the link and info along:

I’ve been unable to reproduce any “skew” here, and the bounding box around the cheetah here looks pretty accurate. The only thing that seems weird to me about this media asset is how far away the hamburger menu is from the bottom right-hand corner of the image.

Along those lines, that particular image is very small (smaller than the image sizes we recommend for media asset upload), so that is very likely why it’s giving you “wonky” vibes on the encounter page?

Am I understanding your second problem accurately here, or is there something I’m missing?

Thank you for working with us on this!

@ACWadmin1 , can you review the above?

Hi @MarkF - for the first issue, it does appear to be fixed; we’ve seen other encounter records where the boxes are not offset as we’ve seen previously.

For the 2nd issue - in this particular instance, yes I would agree that it’s likely because the image is so small.

The researcher has been tracking various issues related to annotations in this dataset and came across this problem this week:
See the annotations in these specific encounters:

Issue: The 2 annotations to the left were in the right places before matches were run (as they were manually added by the researcher) but displayed “off-target” after matches were run - as they are showing now - they are each shifted left of where they were originally added.

This again appears to be something that happens where the original media asset is an unusual shape - overly portrait/tall or overly landscape, for example.

So it looks like some of the issues are resolved but some remain.

Hope that helps.

Hi, Maureen!
Thank you for providing the additional examples. I plan on looking at these on Thurs/Fri. of this week.

I’ll definitely report back when I find out more about the new examples.


1 Like

Hi, Maureen!
This issue is being tracked internally as WB-1392 subtask WB-1518.

1 Like

Hi, Maureen!

Phew. I think it’s possible that I’ve finally fixed this issue, although it hasn’t yet gone through the whole code review and QA process. I ended up having to test some behavior on the production server, so the fixes are live on ACW currently. If you delete any old, problematic annotations on those wonkier images and re-draw manually, they should look better now. Can you confirm that this fixes the issues that you and your team were experiencing?

Incidentally, if you can find any examples of “portrait” style images that are still giving you trouble, I’d love to hear about those!

Thank you,

Hi @MarkF, I don’t think it’s fixed. And we seemed to have gained an extra annotation now, as well.

Re: this encounter record (mentioned above on Feb 17) :

The middle annotation seems properly placed now, but the one on the cheetah below that, the annotation on the far left, is still not where it was placed. In addition, there are now 2 annotations on that far left cheetah, not sure why.

Re the other encounter mentioned above on Feb17, it is now missing the media asset altogether - where did it go?

Lastly, I’m not sure if this is related but today we tried to “add annotation” to a different user’s data and the annotation did not stay where it was put. The researcher tried it using his login and tried it with my admin login and both times, when we clicked to set the 2nd corner of the box, it set but offset to the left, and smaller, than we had been attempting to create it. It was strange enough that we recorded it on zoom - here’s the 30sec video of this new issue:
Passcode Required - Zoom Passcode: P0$HiAaH

This new issue now means that “add annotation” isn’t working well enough to be used as is. So it’s become a little more urgent to address this. Sorry! I wish I could say it’s fixed.


Hi, Maureen!
It’s possible that you guys were doing that right as I was in the process of troubleshooting, for which I apologize if that’s the case.
Could I ask you to try to reproduce that problem again currently?

And regarding the screenshot you sent above, one of those annotations represents me deleting and re-drawing an annotation, and the other has not yet been deleted and re-drawn. What happens when you delete and re-draw?

Thanks for continuing to work with me on this,

Re: It’s possible that you guys were doing that right as I was in the process of troubleshooting, for which I apologize if that’s the case.
→ What specifically are you referring to here? I’m not sure what you want me to recheck. Also, we didn’t work on this encounter record after we posted the issue.

Re: screenshot of double annotation. First, I can’t add a new annotation bec that functionality isn’t working properly per note above. Also, I’m not sure why we’re re-drawing, especially as a virtual duplicate of the problematically placed annotation? The issue was in where the annotation was displaying - what I reported was that it displayed properly after your first round of fixes, I believe, but then when the researcher ran matching, the annotations then displayed offset.

So are you asking me to do the following? Delete one (or both) of these 2 encounters with the smaller than required/duplicated annotation and then go back and add a new one and then run matching and see if the problem reproduces of offset annotations post matching recurs?

Sorry, I’m confused by your note.

Hi, Maureen!
I made a quick video that I hope answers all of your questions from above. Please let me know if it does not.


@ACWadmin1 let me know if the above video satisfactorily answered any lingering questions.

@MarkF - unfortunately, not exactly.

  1. double annotation - I don’t think you’ve noticed what I’m referring to here. In your video, you drew a new annotation for the bottom left cheetah but did so over two bad annotations. What I’m saying is, why are there 2 there now? I can delete them but I don’t know why there’s a 2nd bad one in the first place. See new screenshot below:

  2. The missing image is in the other encounter link I provided above, here it is again:; screenshot below:

As you can see, this encounter/annotation had been assigned to individual CH00015 but we have no idea now which annotation from the sighting is that ID’d one. I think that what may have happened is that you selected “remove annotation” on this encounter. We don’t use this function for exactly this reason - because where there are other annotations on the same media asset, removing this annotation removes the media asset from the gallery of that encounter record. There are 51 encounters in this sighting and the process to find the missing annotation from those 51 encounters takes a massive amount of effort. So we don’t use “remove annotation”.

So my 2 outstanding issues are per above - how did the extra bad annotation show up on the bottom left cheetah, per #1 above and #2 - where is the annotation (and media asset) for this assigned encounter:

The last issue we experienced on Friday was that when adding an annotation, the box jumped to a position in the image that isn’t where we had placed it. That issue hasn’t recurred so I assume it was a result of us trying to do this while you were simultaneously fixing something related in production.

For the last item, I’m happy that Add Annotations is working now but in future, can I ask you to notify me when you’re making changes to the system so I can notify the users and have them log out for the time required?


Hi, Marueen!

Thank you for the response.
I’m afraid that I am to blame for both the duplicate manual annotation you’ve pointed out and the encounter missing a media asset, which I also suspect resulted from deleting a manual annotation.

Going forward, I will notify you and your team when I have to test things in the production server (it was too difficult to reproduce your cheetah image behavior in a test environment) with sufficient advance notice.

I had not realized that your team was not in the practice of removing manual annotations. Let me stew on the issue you’ve raised here and chat with the team members and see if I can help in any way. The way you describe it makes it seem like it’s currently an un-useable feature for you.

This coming Thursday/Friday (my main support days), are you comfortable if I chase down which of those two manual annotations on the bottom left of the image was “mine” and remove it? Alternatively, you’re welcome to delete both of the erroneous ones, as you mentioned.

I will also try to address the missing media asset issue.

In the spirit of resolving this together,

Hi @MarkF - as long as the extra annotation on the lower left cheetah wasn’t a system caused issue, don’t worry about it, I’ll delete both of these bad annotations.

I have already reported my issue with the “remove annotation” feature here: Remove Annotation - removes image PLUS annotation - #2 by jason
JasonH explained in his reply to that that that function is working as designed and outlined a workaround process to get back the original media asset and re-add the annotation. As you see in this current example, going through the 51 encounters to find the missing one is a lot of work. And we have sightings that have way more encounters than this.

So I then submitted this feature request, outlining my issues with the workaround suggested by JasonH to bolster my case. It looks like it’s been accepted for next-gen, which is great, but doesn’t help us between now and then.

Since then, I have told our users to not use the “remove annotation” nor the “remove image” options. Our workaround is to “add annotation(s)” first, then delete the encounter(s) containing the bad annotation(s).

But in this case (, I don’t know how I can track down the media asset that was part originally part of that encounter record.

And here’s a new problem, I just went to the sighting that that encounter belongs to and can see a number of encounters seem to be missing media assets, if the camera icon is to be believed -

This magnifies the problem a LOT. Thoughts? My first thought is we need to get you a test environment with all our data in it :joy:

But that doesn’t find me those media assets missing from those encounters…