Same annotations in different places depending on view (related to odd media asset size possibly?)

Hi, Maureen!

Phew. I think it’s possible that I’ve finally fixed this issue, although it hasn’t yet gone through the whole code review and QA process. I ended up having to test some behavior on the production server, so the fixes are live on ACW currently. If you delete any old, problematic annotations on those wonkier images and re-draw manually, they should look better now. Can you confirm that this fixes the issues that you and your team were experiencing?

Incidentally, if you can find any examples of “portrait” style images that are still giving you trouble, I’d love to hear about those!

Thank you,

Hi @MarkF, I don’t think it’s fixed. And we seemed to have gained an extra annotation now, as well.

Re: this encounter record (mentioned above on Feb 17) :

The middle annotation seems properly placed now, but the one on the cheetah below that, the annotation on the far left, is still not where it was placed. In addition, there are now 2 annotations on that far left cheetah, not sure why.

Re the other encounter mentioned above on Feb17, it is now missing the media asset altogether - where did it go?

Lastly, I’m not sure if this is related but today we tried to “add annotation” to a different user’s data and the annotation did not stay where it was put. The researcher tried it using his login and tried it with my admin login and both times, when we clicked to set the 2nd corner of the box, it set but offset to the left, and smaller, than we had been attempting to create it. It was strange enough that we recorded it on zoom - here’s the 30sec video of this new issue:
Passcode Required - Zoom Passcode: P0$HiAaH

This new issue now means that “add annotation” isn’t working well enough to be used as is. So it’s become a little more urgent to address this. Sorry! I wish I could say it’s fixed.


Hi, Maureen!
It’s possible that you guys were doing that right as I was in the process of troubleshooting, for which I apologize if that’s the case.
Could I ask you to try to reproduce that problem again currently?

And regarding the screenshot you sent above, one of those annotations represents me deleting and re-drawing an annotation, and the other has not yet been deleted and re-drawn. What happens when you delete and re-draw?

Thanks for continuing to work with me on this,

Re: It’s possible that you guys were doing that right as I was in the process of troubleshooting, for which I apologize if that’s the case.
→ What specifically are you referring to here? I’m not sure what you want me to recheck. Also, we didn’t work on this encounter record after we posted the issue.

Re: screenshot of double annotation. First, I can’t add a new annotation bec that functionality isn’t working properly per note above. Also, I’m not sure why we’re re-drawing, especially as a virtual duplicate of the problematically placed annotation? The issue was in where the annotation was displaying - what I reported was that it displayed properly after your first round of fixes, I believe, but then when the researcher ran matching, the annotations then displayed offset.

So are you asking me to do the following? Delete one (or both) of these 2 encounters with the smaller than required/duplicated annotation and then go back and add a new one and then run matching and see if the problem reproduces of offset annotations post matching recurs?

Sorry, I’m confused by your note.

Hi, Maureen!
I made a quick video that I hope answers all of your questions from above. Please let me know if it does not.


@ACWadmin1 let me know if the above video satisfactorily answered any lingering questions.

@MarkF - unfortunately, not exactly.

  1. double annotation - I don’t think you’ve noticed what I’m referring to here. In your video, you drew a new annotation for the bottom left cheetah but did so over two bad annotations. What I’m saying is, why are there 2 there now? I can delete them but I don’t know why there’s a 2nd bad one in the first place. See new screenshot below:

  2. The missing image is in the other encounter link I provided above, here it is again:; screenshot below:

As you can see, this encounter/annotation had been assigned to individual CH00015 but we have no idea now which annotation from the sighting is that ID’d one. I think that what may have happened is that you selected “remove annotation” on this encounter. We don’t use this function for exactly this reason - because where there are other annotations on the same media asset, removing this annotation removes the media asset from the gallery of that encounter record. There are 51 encounters in this sighting and the process to find the missing annotation from those 51 encounters takes a massive amount of effort. So we don’t use “remove annotation”.

So my 2 outstanding issues are per above - how did the extra bad annotation show up on the bottom left cheetah, per #1 above and #2 - where is the annotation (and media asset) for this assigned encounter:

The last issue we experienced on Friday was that when adding an annotation, the box jumped to a position in the image that isn’t where we had placed it. That issue hasn’t recurred so I assume it was a result of us trying to do this while you were simultaneously fixing something related in production.

For the last item, I’m happy that Add Annotations is working now but in future, can I ask you to notify me when you’re making changes to the system so I can notify the users and have them log out for the time required?


Hi, Marueen!

Thank you for the response.
I’m afraid that I am to blame for both the duplicate manual annotation you’ve pointed out and the encounter missing a media asset, which I also suspect resulted from deleting a manual annotation.

Going forward, I will notify you and your team when I have to test things in the production server (it was too difficult to reproduce your cheetah image behavior in a test environment) with sufficient advance notice.

I had not realized that your team was not in the practice of removing manual annotations. Let me stew on the issue you’ve raised here and chat with the team members and see if I can help in any way. The way you describe it makes it seem like it’s currently an un-useable feature for you.

This coming Thursday/Friday (my main support days), are you comfortable if I chase down which of those two manual annotations on the bottom left of the image was “mine” and remove it? Alternatively, you’re welcome to delete both of the erroneous ones, as you mentioned.

I will also try to address the missing media asset issue.

In the spirit of resolving this together,

Hi @MarkF - as long as the extra annotation on the lower left cheetah wasn’t a system caused issue, don’t worry about it, I’ll delete both of these bad annotations.

I have already reported my issue with the “remove annotation” feature here: Remove Annotation - removes image PLUS annotation - #2 by jason
JasonH explained in his reply to that that that function is working as designed and outlined a workaround process to get back the original media asset and re-add the annotation. As you see in this current example, going through the 51 encounters to find the missing one is a lot of work. And we have sightings that have way more encounters than this.

So I then submitted this feature request, outlining my issues with the workaround suggested by JasonH to bolster my case. It looks like it’s been accepted for next-gen, which is great, but doesn’t help us between now and then.

Since then, I have told our users to not use the “remove annotation” nor the “remove image” options. Our workaround is to “add annotation(s)” first, then delete the encounter(s) containing the bad annotation(s).

But in this case (, I don’t know how I can track down the media asset that was part originally part of that encounter record.

And here’s a new problem, I just went to the sighting that that encounter belongs to and can see a number of encounters seem to be missing media assets, if the camera icon is to be believed -

This magnifies the problem a LOT. Thoughts? My first thought is we need to get you a test environment with all our data in it :joy:

But that doesn’t find me those media assets missing from those encounters…


Hi, Maureen!
Thanks for all of the extra context; much appreciated!
I’m now suspecting that all of those encounters-with-missing-media-assets are the result of me creating and deleting A BUNCH of manual annotations during testing and failing to appreciate that they were just pooping out encounters.
I think that all that would need to happen would be to delete those encounters (if the encounter was created specifically to house the new manual annotation that has since been deleted, its reason for existence seems to be gone)?

Here’s what I’ll do on Thursday:
Using my test environment (which is workable for this issue), I’ll load a back up of the database from before I started working on this bug fix.
I’ll count the number of encounters associated with this occurrence and confirm that the (hopefully) new media-assetless encounters are from a recent date. If they are, I think we can safely assume that they’re an artefact from my bug testing, and that I simply didn’t clean up after myself. At that point, I think we’re safe to delete the extraneous encounters.

As for finding which encounters are media asset-less, I think that looking for missing camera icons is brilliant!
Ok. Focus, Mark. This is not a support day. :wink:

Hi Mark - sounds like a good plan because at the same time you could look for the encounter that was assigned to CH00015 and the related media asset and somehow restore it to our production system?

Lemme know when you get back to support :wink:


Hi, Maureen!
Ok I did some digging, and I think I can offer us mostly relief!
I restored the database as it was on 5 Feb., 2021 (before I was involved in this particular community thread) in my test environment.

I’m happy to report that those extra, media-asset-less encounters in occurrence were not there previously. As in, they were entirely absent rather than present and containing media assets (see attached side-by-side of older db [left] vs new [right] for this occurrence). Note the negative search result for “edf0” circled in red on the old version and the positive search result for “edf0” circled in red on the new version.

I am fairly confident that this means that the encounters were generated as a result of me continuously creating and deleting manual annotations, and we are free to delete them.

As for the encounter edf08006-dc86-42ef-9265-5b4145403b7b, which is the one associated with individual CH00015? It doesn’t exist in the older database at all, either. I’m guessing I just wanted to test whether assigning a match worked. Unfortunately, I did so many tests related to this bug fix that I cannot remember for certain.

So, largely good news of the variety of, “I only added things rather than changing existing things”.

The one thing that I am confused about is that this individual CH00015 seems to have many more encounters in the new database compared to the 5 feb, 2021 version. Specifically, as of 5 Feb., CH00015 was only associated with two encounters: 05fb252c-831d-4769-9878-af45c7941468 ( and encounter b300f08c-95bc-41b6-89ba-12d89ef3e2f7 ( I wonder whether this increase reflects legitimate work that someone from ACW did since February 5th, given that the images of the new encounters for this individual aren’t familiar to me?

My recommendation would be to delete those encounters on the occurrence “Census_08-09_2.CHEETAH_Original_3_JohannMey” that are missing media assets. I will let y’all do this unless you explicitly ask me to do it.

I will leave the old version of the database up on for you to check out yourself if you want (feel no obligation). If you navigate there and use your normal log in credentials, you’ll be able to compare that Feb. 5 snapshot to the current version.

I will be out of the office next week, so feel welcome to continue perusing that test instance url next week. If you have any more questions about anything, I’ll be happy to answer when I return!

Many thanks for continuing to troubleshoot with me,

Hi @MarkF - the many more encounters linked to CH00015 is likely the work of the researcher to whom this dataset belongs - she works on ACW daily, going through it sighting by sighting. If she came across a sighting of CH00015 that had a lot of pictures in it, then there could be a swath of encounters that get ID’d all at once. So no worries there.

I’ll have a look at the old database link you sent and compare the sighting of Johann Mey there vs the prod system but I expect you’re right in your assessment and that we can just delete those encounters without media assets in the PD system.

Meanwhile, I have a quick question to ask that I’d rather not post here - can you send me your email address? Don’t worry, nothing rude, I promise!


Hi, Maureen!

Glad to hear!

My email address is

Thanks! Just sent you a note. I think this issue can be considered RESOLVED! Thanks so much for your help and perseverance!

Have a great week!


1 Like

Hi @MarkF - I wanted to let you know that we’ve found another example. It’s not a huge deal bec we decided these qualify as unidentifiable but I wanted to show it to you.
I think it’s again related to the odd size/shape of the image (being very landscape). In the screenshot attached here, the boxes added around the 2nd & 3rd cheetahs from the left are offset from the actual cheetahs themselves. The other annotations are correctly placed.
Encounter links:

1 Like

Hi, Maureen!
Thanks for this! I’ve filed a note to investigate Th/Fr.

Hi @MarkF - I’m reporting this to you almost as an FYI, at least low priority. We found another instance of the bounding boxes being in different places.
Ex.1: the annotation is in the right place in the encounter gallery but in a very different place in the match result target image:
Match: Wildbook for Carnivores

Ex2: the annotation was manually added by the researcher in the encounter and after that, the annotation displays in the encounter as materially offset from where she drew the box. But in the match results, the target image displays the annotation in the correct location (around the cheetah):
match: Wildbook for Carnivores


1 Like

@ACWadmin1 cross-posting here that WB-1634 fix has been deployed (from the post that was split out from this one).

2 posts were split to a new topic: Misdrawn bounding boxes as possible symptom of exif issues?