SAS USA very slow uploading

In which Wildbook did the issue occur? SAS USA

What operating system were you using? (eg. MacOS 10.15.3) variable

What web browser were you using? (eg. Chrome 79) variable

What is your role on the site? (admin, researcher, etc) admin

What happened? the SASUSA uploads have been very slow. This includes photo uploads as well as spot mapping uploads. I have run upload speed diagnostic tests and we have about 18 Mbps

What did you expect to happen? faster upload

What are some steps we could take to reproduce the issue? try to upload image

If this is a bulk import report, send the spreadsheet to with the email subject line matching your bug report

Hi @Carol

It looks like a factor of image size. A 50kb image submission was almost instantaneous. A 12MB image upload took about 45 seconds. We do have several things that happen on the backend that may increase response time since they also depend on the image size, such as rendering low-res copies for web display and image registration with the machine learning server.

At the moment, there are no obvious ways to improve the submission time unfortunately since all of these steps happen together for data integrity.


Thanks Jason - We have much longer upload speeds than you noted on various machines. The Wi-fi at the university is really fast for upload (around 128 Mbps). Even at my house where upload speed is about 70 Mbps it is not this low. For a smaller image (167 kb) today at the university, it took about 5 minutes to upload an additional image to an existing encounter.The spot mapped images are even longer, up to about 10 minutes according to my students.

Typically our uploads have historically been in the range of what you noted - small images in a few seconds, and larger images in less than a minute. So what we are experiencing in the last few weeks is not normal so I wanted to report it to you in case there was something amiss.

It seems something like this happened a while back a few times and maybe there was a server reset that fixed it? Sorry, I don’t really recall any more details about that. It may have been Colin that fixed it though.

Anyway, thanks for your help!

Hi @Carol

I just did a server restart. Please let me know if that helps a little.