SeadragonSearch annotation/match results issue

What Wildbook are you working in? SeadragonSearch

What is the entire URL out of the browser, exactly where the error occurred?

https://wildbook.seadragonsearch.org/encounters/encounter.jsp?number=44ec1f26-4c86-4fb9-8393-0b0de621a745

Can you describe what the issue is you’re experiencing?

Not sure if this is a full-on bug because it’s only happening with one encounter so far, but it seems that this particular encounter won’t annotate and search properly. Nerida tried manually adding a head annotation, deleting, and re-uploading the encounter, but no luck.

Can you provide steps on how to reproduce what you’re experiencing?

Possibly trying to add a manual annotation and seeing how it ends up off of the seadragon’s head…

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Hi, Chrissy!
May I experiment a little bit tomorrow on y’all’s production server by uploading another encounter with this same image tomorrow/later this week?
-Mark

Hi @MarkF ! Sure that sounds good to me, will just loop @NeridaWilson in as well that that’s the plan :slight_smile:

@MarkF do you have a ticket number for this one? We like to add those to our encounter notes to remember what’s what :slight_smile: Thanks!

Hi, Chrissy!

I have reproduced your error.
I initially thought that it might be because the image was really big.
Note:

" We do not recommend using images larger than 1600px in width or height. A compression ratio of 90% is sufficient. Uploading larger photos with higher compression ratios will not improve the quality of your identification results. In fact, unnecessarily large images put a strain on the server and cause identification to take longer.

We recommend using images no smaller that 480px in width or height. When running detection and ID on assets, images smaller than 480px x 480px are resized up, which can cause blurriness, which in turn can cause unusual detection results."
From Photography guidelines | Wild Me Docs.

However, when I resized the image and tried again, I also did not get any detection/bounding boxes.

I also tried a completely different image and got the same behavior, so this is definitely a bug!

Thanks for brining it to our attention. It’s being tracked internally as WB-1533.

Thanks!
-Mark

1 Like

Thank you for the update @MarkF ! We’ll stand by as you investigate and just let me know if I can help out with anything.

Hello all,

I’ve taken a look at this and have some information. It looks like this image was rotated manually with outside software and the EXIF data produced from this is faulty or isn’t being correctly parsed by the encounter page.

That is why the manual annotation appears to float off the image- it is being read as if the dimensions are flipped.

I was able to suppress this by using a couple online tools.

Stripping off the bad EXIF data: View Exif data online, remove Exif online

Rotate the raw image again and save: Rotate image online

The resulting image I sent to Wildbook again, and not only does the orientation appear correctly but the head annotation was detected correctly without manual annotation:
https://wildbook.seadragonsearch.org/encounters/encounter.jsp?number=cdd3efe2-41d1-4750-817c-fd2810024743

I also sent the EXIF stripped image prior to rotating again and it ran through detection successfully, though ID suffered a bit due to the orientation:
https://wildbook.seadragonsearch.org/encounters/encounter.jsp?number=03273ca1-d3b8-46af-9ad1-aff79a8a7f6a

EXIF data can vary between cameras and software tools and it’s nigh impossible to account for everything, especially if the device that took that picture and the tool used to modify the data don’t match up.

I’d suggest either avoiding outside tools for rotation or sticking to one that has been proven to work, and keeping in mind that a camera that saves things a little differently can throw things like this off now and again. I think that using the method above to strip the EXIF data and then rotate should avoid this if it pops up again.

Thanks!

2 Likes