Unable to "add annotation" - the actual bounding box

What Wildbook are you working in? ACW

I was screen sharing with a user as he attempted to manually add an annotation. He was able to click “add annotation” and then selected the viewpoint and species, but when he tried to click to add an annotation on the image, nothing happened. We could see the yellow guide-lines but when he clicked at the corner of the animal, the annotation wouldn’t start, if that makes sense. He tried refreshing the page, starting over, using a different (Chrome) browser, and then tried with a couple of other media assets but was unable to create a bounding box in any of those scenarios.

He’s using a MAC with the following setup:
OS: Big Sur 11.5.2
Safari: Version 14.1.2
Chrome: Version 97.0.4692.71

Any ideas why this is happening?


Hi @ACWadmin1

Can you please send a link to this instance? The URL at the top of the annotation page should get us to exactly what you’re seeing.


1 Like

Hi @jason, I’ll ask him to send me an example. I’ll add it here when I get it. Thanks


Encounter link: Wildbook for Carnivores | Login
Add annotation screen link: Wildbook for Carnivores | Login
Recording of issue: Passcode Required - Zoom
Note: passcode & link sent to services@wildme.org email address.
Per the recording, an icon appears over his cursor when he hovers over the image trying to add the annotation; I’m not a MAC user so I’m not sure what this indicates but it could be why he’s unable to create an annotation. Also interesting is the fact that he is able to add an annotation outside of the image on the “add annotation” screen. Sigh…

We recorded the issue this am via zoom.
I logged in using the user’s credentials on my laptop: HP OS: Windows10, browser: latest Chrome.
I was able to successfully add an annotation on the same media asset that he wasn’t able to. So it’s definitely something on the system side.

Any assistance/advice would be greatly appreciated. If someone else is using a MAC on Wildbook and is able to successfully add annotations manually, if you could let me know what system setup is being used, I’d appreciate it. We’re desperate here - he needs to add A LOT of annotations (it’s wild dogs after all)…

thank you!!!

Hi @jason - the user sent these 2 url’s as examples, per your request:



Hope that helps along with the video clip I sent separately.


Hi, Drew here, I tried to replicate this since I am also on a mac.

I noticed in the video, it sounds like the user is holding down his mouse click to drag to the opposite corner. It works if you release the mouse between corners—a separate click per corner. Does this fix the issue?

I was able to replicate the behavior in the video by holding down the mouse click, but had no issues creating an annotation with two separate clicks. I am on macOS 12.1, Monterey, using Safari.

Hope this helps,


Hi @Drew - how are you? Happy New Year!!! Thanks for testing this out for us. I thought he was doing a ‘click-release + click-release’ approach but I could be wrong and I didn’t check with him at the time of the video so I’ve sent him a note to check now. I apologize if this is the root cause as I should have confirmed this myself.

I’ll provide an update here once I’ve heard back from him.

Have a great weekend!


1 Like

Hi @Drew - I’m happy and sad to report that the user has confirmed he was using a “click & drag” rather than a “click & release” method. Sorry to have wasted your and @jason’s time - I should have caught this.

Thanks again for your help!


1 Like

Hi Maureen,

That’s alright! It’s an understandable mistake. Glad I could help. Happy New Year to you too!


1 Like