Unable to upload, it says 413 Request Entity Too Large

In which Wildbook did the issue occur?
Manta Matcher

What operating system were you using? (eg. MacOS 10.15.3)
macOS Big Sur 11.11

What web browser were you using? (eg. Chrome 79)
Safari ver. 14.02 & Chrome ver. 91

What is your role on the site? (admin, researcher, etc)
manager; researcher; reviewer; local; imageProcessor; approve; identifier; adoption; Indonesia; Indonesia-Komodo; Indonesia-Nusa Penida; Indonesia-Raja Ampat; Indonesia-Sangalaki

What happened?
I was uploading manta pictures as usual. The picture sizes I usually upload vary between 40KB to 1.8 MB, with picture format as .jpeg and .png. I tried to upload an encounter but a ‘413 Request Entity Too Large’ page came up. I tried switching from WiFi to cellular data, and the same problem appears. I changed the manta picture, and the same thing happened. I switched from Safari to Chrome, and the same thing happened. Meanwhile, last week I just uploaded a lot of manta encounters manually (not using the bulk upload feature).

What did you expect to happen?
I expect the encounter to be uploaded and submitted to Manta Matcher.

What are some steps we could take to reproduce the issue?
Help me why it’s happening? :smiley:

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report


cc @E.Germanov

Hi, @argeswaraj !

Could you email the picture that failed to mark@wildme.org?

Many thanks,

Just to jump in here: an iot user I know reported similar issues.

@E.Germanov !
If you or the user could send an image to mark@wildme.org, that would help immensely at getting to the bottom of this!

Also, it is definitely recommended to follow the image-formats-and-sizes in the documentation, so do have a look at that if you haven’t had the chance yet.

Hi, @argeswaraj !
Thank you for sending me those images!
I was able to reproduce your issue for both 20210508-1029-INNLP0522A-MP [b] (M.A.Nor.N.LP.RP.Cr).jpg and 20210508-1029-INNLP0522A-MP [c] (M.A.Nor.N.LP.Cr).jpg.

Simply resizing the images resolved the problem in both cases.
I see that you are also a mac user, so note that the application “Preview”, which comes pre-installed in modern macs, has IMHO a pretty user-friendly image resize feature (just go to Tools → Adjust Size → I usually pick 1000 px width and let it auto-adjust height → save a new file → upload that one) :

I can’t readily explain why this used to work for you in the past and no longer does (I fully updated Manta today, so it has all of the newest bug fixes, etc.), but the image sizes are indeed 2-4 times as large as the max recommended size in our guidelines.

I’m going to mark this issue as resolved for now, but feel free to post other upload errors that you suspect are related to this if you cannot resolve them with a resize. I will break it out into a separate topic if need be.


Thank you Mark,
I am just going to post this for here as another quick for Mac users for resizing using the Terminal App:

Elitzas-MacBook-Pro:~ Elitza$ cd desktop
Elitzas-MacBook-Pro:desktop Elitza$ mkdir temp
Elitzas-MacBook-Pro:desktop Elitza$ cd temp

manually moved

sips -s format jpeg *.png --out ./
sips -Z 1000 *

(The png cose just turns the batch of images all to jpg in case some were screenshots)


1 Like

Ahh this helps! Will make sure to resize them from now on :slight_smile: thanks Mark!

1 Like