Uploaded bulk photos not seen in gallery

What Wildbook are you working in?
Giraffe Spotter

What is the entire URL out of the browser, exactly where the error occurred?

Can you describe what the issue is you’re experiencing?
I just see this error on my photos which I uploaded via bulk import
Hit an error.
org.apache.jasper.JasperException: javax.servlet.ServletException: java.lang.StackOverflowError

Can you provide steps on how to reproduce what you’re experiencing?
I uploaded photos through bulk import and it was successful import. After looking for them on my uploads the list is there but after clicking on the photo, on the gallery part it pop the above error. Also, when searching for the encounters in the study site (ANP) the results list all the photos but when I click on the one I uploaded via bulk import I go the same error in the gallery area.

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Thanks for reporting this. I am able to see the same issue when looking at the link you provided, so it is definitely something related to the import.
As you are managing your own uploads, I have elevated your account to have “orgAdmin” rights. This should enable you to try to delete and reimport this import. Go to Administer > Bulk Import Logs and select the import, then try deleting it.

We had a number of outages and service issues with the storms in Portland over the last few weeks. Hopefully that’s what caused the issue. If you delete, reimport, and still see the same problem, please report back here.


Helo @tanyastere

Thank you for your feedback, however when I clicked at the administer tab I don’t see that option of Bulk Import Logs see the screen below

Can you help me to fix this.


Can you try hard refreshing your cache to make sure?

Hello @tanyastere

I tried the hard refresh but I don’t see that option of Bulk imports logs under Administer tab.


Hello @tanyastere

I’m still waiting for your help on this, or if anybody can help me to fix this will be very much appreciated as I’m hesitating to upload more photos.


Hi Abraham,

We have tracked your issues under ticket WB-1549. I’ve made a couple changes, and you should now be able to see the import options under the admin dropdown when logged in.

Also, here is a link directly to your import:

I can confirm that there was an problem processing the images. The encounters you uploaded retained reference to images that do not exist in the system, and that is why you see the error on the encounter page.

My recommendation like Tanya’s is to remove the import and try again now that you can reach the import page. If this occurs a second time, please reply to this thread and send us a sample of the images you are trying to upload so we can check system permissions and other factors.


Hi @colin

Thank for resolving this problem as now I can see the Bulk Import Logs under Administer tab however I have another problem. After accessing my bulk import and try to delete them, the action results displays the massage displays this message.

Failure! I failed to delete this ImportTask. Check the logs for more details.

Can you help me to fix this too.


Hi Abraham,

I did indeed find a problem in the deletion of your import. I’ve solved it and in the process
deleted the import. You should not encounter it in the future.


Thanks @colin for your help, thinks are now working.

1 Like

A post was split to a new topic: Encounter Gallery Images no Visible