URGENT- Participants unable to submit encounters

What Wildbook are you working in?

SeadragonSearch

What is the entire URL out of the browser, exactly where the error occurred?

This was reported to me by one of our volunteers so I don’t have a URL.

Can you describe what the issue is you’re experiencing?

Hi Wild Me team,

I just received this message from one of our regular submitters and hoping you can advise on what to do to fix this- let me know if you want his email address or want to ask him questions through me! This has only been reported by one person so far but I really want to make sure it’s not happening to others:

“Hi Chrissy, just letting you know I haven’t been able to submit pics to the Seadragonsearch site since Sunday. I can fill in all details but when I hit “submit” nothing happens. The verification button too seems to be missing so not sure if that’s part of the issue? Apologies if you’ve already been informed multiple times. -Steve”

Can you provide steps on how to reproduce what you’re experiencing?

No because I haven’t had this issue myself, but it might be related to something that happened recently to @NeridaWilson receiving an error message when trying to submit an encounter.

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

@ChrissyTustison

I was able to submit without issue both as a logged-in user and while logged out. Chrome and Firefox show the button.

Unfortunately, we cannot reproduce this.

I also don’t believe we have done any new work on this server in quite some time. The drives have plenty of space too.

Thanks for the quick reply @jason! I will check back with him to see if he’s still experiencing the same issue…

Hi again @jason- Steve confirmed that he’s still having the same issue and sent me a screenshot, which I believe shows the same error message that @NeridaWilson was getting a couple days ago… Does this help or are there other questions I can ask him to figure out what’s happening? The reporting page is working fine for me too- is there a reason it might not work in Australia specifically?

Which browser and operating system is this? Can you also ask if he has cleared his cache recently? For example, if Google updates their reCaptcha code, we might pick it up, and he may have a stale version of their old code.

There should be no difference with him calling it from Australia.

@jason thanks, I will double check those things with him…

Hi @jason, I’m back with more info!

This was Steve’s reply to my inquiries:

"I am getting the same issues using an entirely different computer now. As mentioned previously, I had issues on my home NBN, using my phone as a Hotspot thru Telstra and now on an Education Dept system.

Both computers are Macs and I’m using Firefox on each.

I have however (using the Ed Dept system) tried using Safari to no avail there either?"

Does this help at all with figuring out what might be happening? Thanks!

Unfortunately, no.

I did use a VPN (TunnelBear) to simulate access from Australia, and there was no difference. There are many things that could be an issue here:

  • Anything blocked by the user’s network
  • Anything blocked by the user’s browser or an extension
  • Anything cached in the user’s browser

Beyond that, we can’t reproduce this and so it’s difficult to say what might be happening.

I have another person in Australia who cant submit, same error- he cant use his phone either. Interestingly he is a new user, first submission so cant be cache issues, right? He said he didn’t even have the option to refresh the reCAPTCHA.

I did a test on my work computer- was able to submit fine…but cant do another one. I get the dreaded error. I am on a mac with chrome.

@NeridaWilson, I changed our recaptcha site key. We can’t reproduce this, so we’re flying blind here.

After clearing your browser cache, are you able to successively submit multiple encounters without the error?

Thanks,
Jason

Now I cannot submit at all (the button just seems unclickable), and no reCAPTCHA motif present

What @NeridaWilson describes here is also what Steve Norris described as far as the button being unclickable, @jason

Well it turns out now it just behaves differently (ie seems unclickable, but still works actually). So now without the reCAPTCHA thingy I can submit. But it sure doesnt feel like anything has happened from the submitters end.

I have asked a new submitter to do a test one if he has time. Lets stay tuned. @Chrissy do you want to ask Steve the same?

Two quick requests:

  1. Do you see the same issue here: https://www.whaleshark.org/submit.jsp

  2. In Chrome can you please hit CTRL-SHIFT-J on the page and send me a screenshot of any red errors or warnings? Mine (below) is empty, but I’m hoping there may be some hint for you.

I have done more device and browser testing on my side and still cannot reproduce.

Thanks,
Jason

Hi Jason, no problem with the whale shark one here…