Whiskerbook new ID error

In which Wildbook did the issue occur?
Whiskerbook
What operating system were you using? (eg. MacOS 10.15.3)
Windows
What web browser were you using? (eg. Chrome 79)
Google Chrome
What is your role on the site? (admin, researcher, etc)
Researcher/
What happened?
When I use hotspotter algorithm, and I want to add a new id between two photos, then it will tell me there is an error. The new ID is applied but it shows an error message.

What did you expect to happen?
a message that says Success.

What are some steps we could take to reproduce the issue?
Match something with hotspotter and then attempt to add a new ID to a match of two photos.

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

@evebohnett

Can you please provide a link to the result and a screenshot?

Thanks,
Jason

Here’s an example, although this is common in all cases.
When using hotspotter, if I check the box next to inspect and add a brand new individual ID


Then it says in the same corner: Error updating encounter: Please enter a different ID.
However, when I reload the page the ID has been applied. It’s some kind of message bug. It should say Success! your encounter has been updated with the new ID. Or something like that.

Here’s the link to this case, and as you can see the ID did take. Anytime I use hotspotter to match images and apply a new Id it always done this. The ID merge feature works just fine, but applying new IDs has that message bug.
https://www.whiskerbook.org/iaResults.jsp?taskId=dcdc2565-978f-4514-a73c-ac61961eac2a

I should also mention that even if the new encounter is applied to an existing ID… that error is also present. See here I tried to set an encounter without an ID to one of the hotspotter matches with ID 114, and in the righthand corner, it says Error updating encounter…but it worked and the ID was applied. It’s just a message error. The application actually works every time. The message is wrong.
capture3

Hi @evebohnett,

Great example.

https://www.whiskerbook.org/iaResults.jsp?taskId=dcdc2565-978f-4514-a73c-ac61961eac2a

This seems to be an interesting edge case. The annotation to match and all match candidates are from the same Encounter. Our logic is assuming two different Encounters and then setting the ID on the first and then attempting to set the ID on the second…only to throw an error because it is the same encounter and has an ID! I would expect this occurred as a result of matching in a bulk import.

I’ll try to close this error with a better message an gracefully handle the same-Encounter match scenario.

Filed as WB-1669.

Thanks!

1 Like