Bulk Import xlsx- columns reading incorrectly

In which Wildbook did the issue occur?


What operating system were you using? (eg. MacOS 10.15.3)

Windows 11

What web browser were you using? (eg. Chrome 79)

Microsoft Edge

What is your role on the site? (admin, researcher, etc)


What happened?

I uploaded my xlsx spreadsheet along with the image folder ‘ID_2021/xxmediafilesxx.png’. The ‘Encounter.mediaAssetX’ and ‘Encounter.measurementX’ columns are showing as detected but incorrect (aka yellow in the review page (see image below)).

I tried a few different formats to try to get the correct output, however with no success. For the media asset column, the formats for image names that I tried were:

For the measurement column, I made it go to the tenth of a meter (3.9, 4.2, etc), as well as round to the nearest whole number (3, 4, etc), although I would rather have no data than rounded to the whole num.

My original thought was that the columns with periods messed with the import code, however the rounding to whole numbers in the measurement column seems to have ruled that out.

What did you expect to happen?

All columns should be accepted in the xlsx review page

What are some steps we could take to reproduce the issue?

Follow the formats I provided for image names going into media asset column. The spreadsheet that I emailed to services@wildme.org have the image names and the uploaded folder is “ID_2021”.

If this is a bulk import report, send the spreadsheet to services@wildme.org with the email subject line matching your bug report

Hi @Dmoran

Some of your fields still have placeholder values in them that need to be replaced so they can import correctly:


“X” is a placeholder that should be replaced with a number starting with zero. You have additional fields with placeholders in your spreadsheet, but only the ones above have data associated with them.

From our Bulk Import Cheat Sheet:

1 Like