Detection requests do not load

What Wildbook are you working in?

What is the entire URL out of the browser, exactly where the error occurred?
Flukebook | Login

Can you describe what the issue is you’re experiencing?
Computer Vision Status: detection requests sent (0/42 complete). Each detection job in the queue is currently averaging a turnaround time of 9 minutes.
The detection request is running for now 3 days but does not advance, it remains at 0/42. I also tried to start a second detection with other photos but I have the same problem. For information I am working on pilot whales.

Hi @rebeca

Can you try deleting and then resubmitting the bulk import? If the new import also stays stuck without running detection, let me know so I can research it further.

I just tried and it still doesn’t work

Thanks for letting me know. I need to research this a bit more.

1 Like

Thank you. Let me know if you need anything to find out where the problem comes from (the Bulk import excel file for example). I tried again today and it still doesn’t work, What is surprising is that there are several of us on the same account importing photos of different species and the Bulk Imports of the other species work.

1 Like

That’s helpful context; thank you! I’m still looking into this and will let you know as soon as I have more details.

1 Like

Hi @rebeca - I’m the community manager for the African Carnivore Wildbook. We use bulk imports extensively. While this may be a problem on the server side, I’ve seen that a minor misspelling of the species and epithet, even using upper case instead of lower case on the latter, can cause detection to not run. If you’ve already verified all of your spreadsheet content then this obviously may not be the issue but I thought I’d mention it, just in case.


cc: @Anastasia

1 Like

Thank you for your message, I think I wrote the species name correctly, Globicephala macrorhynchus. I didn’t have my excel checked so I’ll share an example here if anyone notices an error ? Thanks again for your help @Anastasia and @ACWadmin1.

Hi @rebeca - if it’s not the species spelling, then I don’t see anything in your spreadsheet that looks like it could cause detection to stall. The only thing that’s different from what I’m used to seeing are the dots within your image file names beyond just the one before the jpg extension - have you used this format before without issue? I’ve found that in general, the system really doesn’t like special characters anywhere in the metadata, other than dashes and underscores. That said, I don’t know why that would cause an issue with detection - I’m not a techie at all… But if you’ve used dots within your image file names before without issue than it’s back to the Wild Me team for their input.

Sorry I couldn’t be more help.


Thanks for jumping in with suggestions, @ACWadmin1!

Jason suspects it might be a configuration issue for that particular species since other species Rebeca has bulk imported are being detected correctly.

I’ll update here when that’s been resolved.

Thanks for checking! Originally the file names contained dashes but we renamed them to dots because it says in the Bulk Import documentation that “Your file names should only include a-z, A-Z, 0-9, and period and space.” However, my colleague Louise who works on sperm whales managed to import these photos with the same name format and it didn’t seem to be a problem.

By the way, can you post the link to the import you’re working on so I don’t confuse it with Louise’s?

Okay, I’ll send you the link and the file by email.
Thanks again

1 Like

The species detection has been configured for the short-finned pilot whale. It may take 2-3 hours form now to begin kicking off detection. You should start to see the numbers in your import start to increase from 0/42 as it works its way through the images.

1 Like

Screenshot 2023-03-02 at 4.11.15 PM
It looks like you now have the option to Send to identification on this import. I’m going to marked this issue as resolved now that detection is working for this species.

1 Like

Great, everything works! Thank you very much Anasatasia!

1 Like

A post was split to a new topic: Detection requests do not load: fraser’s dolphin