Grouper Spotter Platform Error message when matching

What Wildbook are you working in?
Grouper Spotter
What is the entire URL out of the browser, exactly where the error occurred?

Can you describe what the issue is you’re experiencing?
On an encounters where I have had to remove the annotation and create a new one and run a new match, it is unable to compete the matching.

Instead of finding a match or saying no match is found after about 15 minutes it just says “attempting to fetch results” but with no loading wheel or anything indicating it is still working on finding a match.

Also on encounters that already have annotations and matches we are getting error message that says.
“Error. Something went wrong when fetching the inspection image.”

Can you provide steps on how to reproduce what you’re experiencing?
Remove annotation
Add Annotation
Start New Match

For the other error - on an encounter that has a match hover over the match number and the error message pops up

If this is a bulk import report, send the spreadsheet to with the email subject line matching your bug report

Thanks @accfish. I’m escalating this to our engineering team as this issue appears to be affecting multiple Wildbooks.

I’ll let you know when I have an update for you.

Thanks for your patience, @accfish. We’ve resolved the bug that was making WBIA start its weekend early. :sweat_smile:

Hello. I see you said you resolved the bug but our two issues don’t appear to be fixed. can you please double check thank you

Hi @accfish

Thanks for letting us know. When I tested your links after the fix was deployed, match results appeared to be displaying correctly.

I just checked the encounter from the matching screenshot you posted and the error message is gone when I hover over the match results:

However, if I go to the match results on one of the other encounters you provided, they don’t load.

Were any of these encounters part of a bulk import? If so, can you email the spreadsheet to services at wildme dot org so I can troubleshoot?

Yes they were all from bulk uploads. It was working fine before though. We will send the info your way

Thanks for sending the file!

When you said you consolidated your bulk imports, did you mean just for the sake of this request, or that you’ve been uploading 5k encounters at once?

Edited to add that I’ve also asked my team about this in case it’s related to a server issue.

Hi @Anastasia

We made sure that we we did bulk imports, we always keep the uploads to under 1000 encounters at a time.

@BTran Thanks for clarifying!

I may not have an update on this until next week. I believe this particular issue may be server-related.

I did notice some special characters in your file names (commas, dashes, underscores, parentheses) that don’t play nicely with bulk imports, but I’m still trying to research whether that alone would cause this error.

Hi @BTran

Thanks for your patience. I’ve flagged this for the team to review, but I unfortunately don’t have a timeline for a resolution at this point.

Just following up on this issue. Is there a timeline for resolution or do you need any more further details from us? Should we avoid approving encounters and uploading any other bulk uploads at this time?

Thanks for your patience and for the reminder to check in!

It looks like there was an issue where the match result did not get back to Wildbook and due to its age (jobs over 30 days old) it was purged from the machine learning server. You should be able to manually re-run the result to view matches.

The bad news is that this issue may have affected all of the encounters that were part of the same bulk import. So it’ll be up to you to decide it makes more sense to manually re-run match results on each encounter or delete the bulk import and re-import it again after removing the special characters from any file names.

Hi Anastasia,
Ideally, we wouldn’t want to have to remove and reupload the bulk upload because I believe the unapproved encounters that are currently in GrouperSpotter are from two different bulk uploads and some of the encounters from each of those bulk uploads have already been approved. So I’m not sure how we can easily remove and add those bulk uploads without duplicating some of the encounters.

When I rerun the matches or I remove the annotation (which is wrong in some cases) and add a new annotation to the encounter and then try to run a match this doesn’t appear to be working still. It spins for a long time (30 minutes), before it quits and leaves the message, attempting to fetch results.

So there is still an issue with these encounters. Unless I am misunderstanding what you mean by manually re-run the result to view matches.
I see you submitted a test encounter and were able to get a match but were you able to run a new match with the currently uploaded encounters?

Also is this going to be an issue later on when we want to rerun matches on some of these encounters that have already been approved? Or will it stop them from being able to match with future encounters? I guess I’m not quite clear on what the error was and whether it is fixed. We have used special characters in all previous bulk uploads.

Thanks for letting me know that re-running matches hasn’t worked and that redoing the imports isn’t an option for you.

@jason There seems to have been an evolution of matching issues here that weren’t fully resolved by January’s WBIA bug fix. Now matches vary from “Image Analysis has returned and no match was found” to “Gave up trying to obtain results”. Re-running matches or removing annotations to add new ones that start new matches also time out and don’t provide match results.

I can’t pinpoint when exactly the change occurred, but sometimes processes change as we continue to develop the product.

From our Bulk Import Cheat Sheet:

The docs say I can’t do XYZ in my spreadsheet, but I’ve done it before without a problem.
Wildbooks are always being improved as a result of testing and user feedback. Sometimes this means that we have to make changes to old processes to make way for new ones. We do our best to keep our docs updated to reflect the most up-to-date information on using Wildbooks. When in doubt, check the docs or post in the Community Forums for guidance.

If needed we can figure out how to remove and re-upload the encounters but it won’t be straight foward so if there is another option that would be ideal. I’m more concerned with previous encounters in these bulk uploads that have already been approved. Will they be able to be rematched in the future or do we need to redo them as well and if so how far back does the issue go?

For instance I just tried to rematch these previously approved encounters and the matching did not work. And when you look at the previous matches they all say “inspection image unavailable (likely outdated)”.

I worked with Jason on this one and because these encounters came from an import in October 2022, he just re-ran identification on the import and it appears to be showing matches again.

I thought re-running matches could only be done one-by-one, so I’m sorry about the scare with that. :sweat_smile:

When matches for an import are being weird, you can just re-run identification without having to re-do the whole import by clicking on “Send to identification” in the bulk import summary.