Issues assigning annotations and creating new individuals in Zebra Codex

Am having trouble in identification today, both giving new ID and Matching new individuals.
Links below, please assist.

Assign annotations to individual • Zebra Codex (

Create individual • Zebra Codex (

Thanks for letting us know! I see the error message for the Annotation page and will share with the devs.

Is there an error message that appears when you try to create an individual? I submitted it as a test, but it looks like it accepted the submission. What was the error you saw with it?

Thank you, here is the error screenshots.
I will test another one right now and give you the feed back.

It looks like in both of the screenshots you posted, that the species hasn’t been set yet. You may need to scroll down the page further to see it:

Same problem just now and the software is extremely slow to open sightings.

Assign annotations to individual • Zebra Codex (

Sightings are loading right away for me. I’m also not seeing any issues in our service dashboards for Zebra. Is it possible that the slow loading may be an internet bandwidth issue on your side?

I’m seeing a different error message on the Annotations page when I click the Assign Annotations button. I saw a similar error in the first link your shared, too:

Are you able to assign any annotations at all or are you seeing these errors for all of your sightings?

This one had species recorded already, the annotation gave me the same error. I closed that screen and opened again. Already it matched the ID, yet the process didn’t go through.

All my sightings today. None is successful.
The same data I was working with yesterday and all was fine.

I’m not sure what you mean when you say it matched the ID, but the process didn’t go through. Can you clarify for me, please?

Below is how I can explain all the steps with images. I hope it’s a bit clear.

After getting the error in screenshot 234, I closed wildbook and opened again the same sighting. Below is the outcome.

I’m going to send you a link so we can set up a call so you can show me what’s happening with this in real-time since it may be faster than trying to work it out over the forum.

Hi @Rosemary

Thanks for meeting with me today! Here’s a summary of what we discussed and answers to some of the open questions:

  • As of Thursday July 20, Microsoft Edge browser hides most of the filters in the Sighting search and does not display the species menu on the Create Individual page after confirming a match. This did not improve after updating Edge to the latest version. I’ve added this to our bug reports and will update this thread when it gets a ticket number.
  • Google Chrome displays all metadata filters in the Sighting search and displays the species menu on the Create Individual page. Use Chrome as a workaround while we find out why Edge isn’t playing nicely with Codex.
  • Pending sightings can’t be accessed by edit Collaborators. Is there a plan for making pending sightings more transparent to collaborators with edit permissions? Not currently, but this is a valid feature request if you want to post one.
  • Who has access to exported data? A user needs to have the Exporter role on their account. These users can export all the data they own and collaborate with: Manage Users - Wild Me Documentation
  • Why does Codex create two identical annotations on a photo of a single animal? (ex: Check the Annotation Class and the Viewpoint for each annotation. If they’re the same, then detection likely made a mistake. In the example you shared with me, both annotations have the same Annotation Class (Zebra) and Viewpoint (Back-right), so it’s ok to delete one as a duplicate.

Let me know if there’s anything I missed or didn’t describe correctly.

Do you mind trying something for me? Sometimes when a website stops working correctly, clearing your browser’s cache and cookies can make things display correctly again.

  1. In Microsoft Edge click on the 3-dot menu (…) and then click Settings then click Privacy, search, and services .
  2. Under Clear browsing data > Clear browsing data now, select Choose what to clear.
  3. Under Time range, choose a time range from the drop-down menu.
  4. Choose the types of browsing data you want to clear (see this link for descriptions).
    For example, you may want to remove browsing history and cookies but keep passwords and form fill data.
  5. Select Clear now.

Then try to confirm matches and look up Sightings in Codex and let me know if they still don’t display correctly.

Thank you so much for your time and support.
I noted that not all Google Chrome has all filters. John, one of our staff has been using Chrome since he started working with WILDBOOK. His page displays like my Microsoft Edge hiding filters, he switched to Microsoft Edge and that solved his problems.

So now mine works well on Chrome and his on Edge…funny!!
Yet we have the same Microsoft Edge Version 115.0.1901.183 (Official build) (64-bit) and same computers, same network.


Both Edge and Chrome are displaying well on my computer.
Thank you.

1 Like

A post was split to a new topic: Can’t edit metadata on Individual page in Codex