Issues logging in; after restart get 502 error

I understand that this is probably not a WIldbook issue; however, we had our version upgraded in December. We currently have only 1 researcher entering data so not much activity has happened on the system since the upgrade. In fact, it was just last week that she tried spot mapping and ran into issues. I was trying to log a bug and I was unable to get logged in and that lead to this Support Request.

What Wildbook are you working in?
Wildbook v.7.0.0-EXPERIMENTAL

What is the entire URL out of the browser, exactly where the error occurred?

Can you describe what the issue is you’re experiencing?
We are on an AWS EC2 Instance

  1. Initially our Cert had expired; I regenerated it
  2. Then I tried to login. Nothing happened
  3. So I tried restarting the AWS Instance
    Now I get: 502 Bad Gateway

Can you provide steps on how to reproduce what you’re experiencing?
Launch URL above

Hello @OceanSanctuaries

That message is a good indicator that Tomcat 8 needs to be restarted. I restarted it, and the site is back up and running.

Some helpful commands for your server only:

To restart the PostgreSQL database: sudo service postgresql restart

To restart Tomcat 8:

  • cd /var/lib/tomcat8
  • sudo bin/
  • sudo bin/


1 Like

Thanks. I probably should have thought of that but I will definitely put this in my notes.

I will be logging the bug issue, seperately, now that I can confirm things.