Matching process only working within my own list of individuals

Hello again !

My first bulk import has finally worked. I went through all the pictures and matched the corresponding individuals. I have two problems:

1- When I go to My Data → View my individuals : sometimes, the exact same individual (same name) appears twice as if it were two different individuals and thus, all the pictures for this particular individual are not gathered. I don’t know if there is a way to fix this.

2- Since I’ve imported a lot of photos (200ish) in my bulk import, when I send to identification, it seems that the matching process only find match within the photos of my current bulk import. I would like to compare my identified individuals with those of others organizations but I cannot find them.

When I’m expanding the Num.results to 50, 200 or even 300 instead of 12, it doesn’t display others photos that mine, even though there is no more photos matching. For instance, for the Num.results of 300, it only worked until 230 and then stopped because there is no more match within the photos of my bulk import.

I’ve tried it with several individuals, thinking that the first one might be a new individual, but nothing changes. It’s really weird because for instance, I know that my first individual (CCS_Pm_0001) is matching one of the DSWP (@ShaneGero) named Canopener.

Have a good day,
Best regards,
Louise :slight_smile:

Can you link to an example? I’m curious if this is similar to another bug report I’ve seen recently.

Matching happens within the Location ID you selected. For example, if you’ve set your location to Hawaii and you’re the only user who’s uploaded this particular species in Hawaii, then you’ll only see matches from your uploads. You can try re-running the matches by selecting additional nearby regions to see if there are potential new matches, or you can revisit this import again in the future and re-run matches at that point to compare against any new uploads that have happened since then.

Yes, no problem. Here it is:

Thank you for your quick answer as always ! Ok, I’m going to try re-run it worldwide to see if there is any other matches.
It’s weird though because I’ve selected Caribbean Sea as the location ID, and both my organization and the DSWP are within this area (Lesser Antilles: Dominica, Martinique, etc).

I’ll keep you update anyway !

Ooh, I should have clarified but don’t run it worldwide. That’s gonna cause a massive delay if you go worldwide because it’s gonna check against hundreds of thousands of photos. I only meant to include additional nearby regions.

Let me research and follow up on why Canopener and CCS_Pm_0001 aren’t appearing as the same individual.

Thanks for this, by the way. This does match the other reports we’ve had about duplicate individuals appearing in Flukebook. Do the duplicates occur when the same individual appears in more than one bulk import?

I looked at a recent Canopener encounter and verified there were similar annotation viewpoints with CCS_Pm_0001 and both have sightings in the Caribbean Sea. I’ll have to follow up with you on this one as well.

1 Like

No, I’ve only done one bulk import so it appears within the same bulk import.
Something I should probably mention:
Because it was my first bulk import, I had put all the pictures in one column under “Encounter.mediaAsset0” and then all the rows. However, sometimes it was a burst of pics of the same individual and the AI couldn’t find that some of them were related to the same individual so I had to set it manually. To do this, I just clicked on the Encounter page and linked this encounter to my already created new individual.
It worked properly at first but then, the new individuals created were not appearing on the drop-down menu. So I had to set a new individual on the encounter page and then it would appear properly in the drop-down menu.

Here for instance, neither individual 15, 21, nor 23 are appearing on the drop-down menu even though they are existing. If I want to link one of my encounter to those existing individuals, I have to “set a new individual ID” just above.

So it could explain a part of the problem. However, even when I had all my individuals in the drop-down menu, I had the issue of the duplicate. But this time, instead of not having it in the drop-down menu, I had the same name twice. But this was a fixable issue by going on “View my individuals”, clicking on one of my individual profile (the first one of my duplicates for instance) and then, on each picture associated. This way I was redirected on each encounter page and could set all the pics on the same individual (choosing the second one of the drop-down menu for instance).

I don’t know if it’s going to help but I found it maybe useful to mention these two cases.

Oh ok thanks and sorry. It’s just that I don’t know how to add a new location ID for the identification function to work with, without deleting my all bulk import and having to put new locations ID directly in the spreadsheet associated to this bulk import.
Indeed, I only have two options in the drop-down menu before sending to identification: “Caribbean Sea” and “All locations”.

That’s helpful context; thank you!

You’re right; I had forgotten that you can only manually update locations when you re-run a match from the encounter page.

Let me see what I can find out for you.

1 Like

I just confirmed that bulk import won’t let you do what I suggested. Being able to refine the location the new match is run can only be done at the Encounter level. :smiling_face_with_tear:

I hope to have an update soon on why Canopener isn’t coming up as a match for CCS_Pm_0001

Thanks for your patience. The reason your match results are limited may be because it’s only searching for exact location matches for “Caribbean Sea” instead of the Caribbean Sea and all of its sub-regions.

You can try re-running identification again on the entire bulk import for all locations. It will take a long time, but this way, Canopener should appear as a match candidate for CCS_Pm_0001.

Hi again @Anastasia !

I’ve tried what you said about running it worldwide but the first results don’t seem to give the right results. It’s still searching for matches within my own bulk imports (against 800ish candidates). I’ve also tried to increase the number of results displayed but it’s still my own photographs.

It’s really weird though because I even tried to precise the location ID from Caribbean Sea to Dominica at the encounter level for CCS_Pm_0001 and it doesn’t match with Canopener neither (If you want to take a look, it’s encounter cef13e10; 2021-05-23 at 9am).

Thanks for the detailed update! I’m going to keep experimenting with matches on this encounter until we can see Canopener as a match result. I’ll let you know as soon as I figure it out.

Edited to add encounter link for my reference

Good news! Either the latest match attempt worked or it was there all along and we were looking for the wrong name in the results. :sweat_smile:

Canopener’s page:

CCS_Pm_0001’s match results for the above encounter:

Hi @Anastasia !

Yes, actually it’s because I went on the encounter page of CCS_Pm_0001 and I changed the location ID for Dominica instead of Caribbean Sea as you said and this way, it appears in my results (matching against 21000ish individuals).

What is really cool is, since I changed the location from Caribbean Sea to Dominica for 1 of my encounter, then it appears in the drop-down menu at the end of the bulk import page to resend to identification. So I did that and it worked pretty well for my first bulk import.

I was super happy and kept doing the same thing for my three others bulk import but now, it’s just stuck and don’t give results anymore (there are still the same messages as earlier about “attempting to fetch results” so I was just keeping hope and waiting for results as you suggested the last time but it’s been 5 days since I relaunched the identification and nothing’s changing.

I’ve just tried to re-run the identification task on one of my bulk import (n°356fb9dd).
So for now I’m just waiting and fingers crossed !

1 Like

Hi there!

I’m sorry to contact you again but I’ve been waiting for a week now for the results of the identification process and it’s still not working. I don’t know what to do anymore.

I’ve restart the identification process for my four tasks about 10 days ago to match against the DSWP catalog with the Dominica location ID. The first bulk import gave me the results but from there, the three others haven’t worked. It’s been launched the 23th of March. When I clicked on the encounter pages, it displayed the following message in red: “there was an error with task … unknown error”. So that’s why, I retried to start again the identification for one out of my three “not working” bulk import but now that I’ve been waiting four more days, the same message is displaying again.

For the last of my bulk import, the beginning of my bulk import displayed the red error message but at the middle, it tells me that the identification process is still going on (but maybe in few days, it will also display the same message since it’s what it happened for the others bulk import).

So I don’t know what to do anymore because I think this is a pretty abnormal waiting time. Do you have any idea how to fix this ?

Best regards,

Hi @lsimon

There was maintenance performed on the Flukebook server earlier this week:

Can you link me to the specific bulk imports you’re still having trouble with and email the spreadsheets that go with them?

1 Like

Hi @Anastasia !

Thanks for the update ! I hope it will work next week though !

I’ve just sent you the excel files and below are the link to the three bulk import having trouble to process the identification:

1-Flukebook | Login
2-Flukebook | Login
3-Flukebook | Login

Thanks for your patience and your help !

1 Like

Thanks for that!

Your spreadsheets for these imports look good.

I know there’s been some unfortunate timing on troubleshooting due to server issues on our end this month. I’m really sorry about that. I’m waiting to hear back about when the latest server restart is complete so I can see if the match issues on these imports were part of the 2600 corrupted identification jobs or if we just should delete these 3 bulk imports and re-upload them.

1 Like

Ok thanks a lot! I hope it will be fine next week :slight_smile:

I just have few more questions:

  • If we have to delete the bulk imports but we already matched and named some individuals within; does flukebook is going to keep the images and information linked to the individuals or delete it all ?

  • Do you have any idea about why sublocations are not taken into account in the Caribbean Sea location ?
    I’m super happy that it worked with the Dominica location ID but I was just thinking that there might be more matches between CCS catalog and other organizations within the Caribbean islands but I couldn’t see it, except if I’m running the identification process for each sublocation of the Caribbean Sea.

  • Did you manage to understand why there are some duplicates of the same name for an unique individual ?

Once again, thanks a lot !