Missing data and adding column in codex

Hi Jon,
I have 3 issues on John Naisiki’s data.

First, kindly add “Sample ID” column on codex metadata. It is there in Excel Wildbook standard format but not in codex.

Secondly, when we go through John Naisiki data, we can’t see sample ID’s from the old data transferred from WILDBOOK to Zebra Codex. Each Individual had its sample Id for genetics lab analysis so its very important to get it. How can it be retrieved back?

Thirdly, John says while exporting excel data sheet to Codex, he ignored sample Id instead of confirming since it couldn’t match with anything. Can that step be redone without going through the whole upload process again? Or he can add it in metadata during identification.


Hi @Rosemary

When you direct your comments to a specific user, they won’t see it unless you put the @ in front of their username.

@jon This question appears to be a followup to this post you helped troubleshoot.

Thanks for correction, I appreciate!

@jon kindly assist on the above issues.


Thanks for your patience, @Rosemary

We’ll need more time to look into this so we can consult with additional teammates. To summarize:

  • You want Sample IDs supported in Codex
  • You previously had Sample ID values saved in Wildbook that you want available in Codex
  • If this data transfer is possible, will it be automatic or does it need to be re-entered manually?

Let me know if I’ve got that right or if I misunderstood something. I’ll follow up with you as soon as I have more information.

Yes, you are right! @Anastasia

Hi @Rosemary

Thanks for hanging in there. I need more time to research this but I hope to have an update for you by the end of this week.

OK, I finally have an update on this!

You can now add Sample IDs to Zebra Codex. We’re working on getting the old sample data from Wildbook transferred over to Codex.

For any bulk imports that didn’t include sample data fields in the spreadsheets, you’ll need to add those manually.

@Anastasia and @Rosemary

I tried to add sample ID manually and got the attached error messages in all individuals.
In the field: Age and Behavior


I edited age to be 3 yrs for it to save the sample ID changes, though the animal is an adult more than 3yrs but the exact age is not known.

Kindly assist.


Hi @0702233452

Do you mean that when you submitted a bulk import, it flagged the Age and Behavior field data as invalid and then you had to manually correct it in Codex? If so, an you email your spreadsheet to services at wildme dot org so I can research this? What was your original input for the age?

The original input for age was adult.

After adding sample ID manually to already identified individuals in codex that’s when Age and behavior flagged off. However, without the sample ID addition, everything was OK.

What is the way forward since we need the sample ID added to every individual in John’s data.

Thanks for your continued support.


Ahh, I understand now. Thanks for clarifying that. Let me raise this with the team to find out why it’s requiring Age and Behavior when Sample data is detected.

It sounds like this is related to a known bug with required fields. This should be fixed by the time version 2.0 of Codex is ready, but in the meantime keep doing what you’re doing to get the Sample data saved. I’m sorry about the extra steps.

When we re_do the behavior field is working, the challenge is Age since it requires a number. For young ones below 3 years is Ok but for adults its tricky. The reason we fill in that field as just adult.
Is there a way that field can remain as Adult as it is in the excel without asking for numbers?


A post was split to a new topic: Bulk Imported Data to Zebra Codex Missing After Upload

That’s part of what we’re working on fixing. This should hopefully be addressed soon to include an “unknown” option instead of requiring an age.

This sounds like a separate issue than what we were already discussing in the thread. I’ve split this into a new topic so that we can track progress on each issue separately as they may have different timelines to resolution.

Per this post: Bulk Imported Data to Zebra Codex Missing After Upload - #11 by Rosemary legacy Sample ID data from Wildbook is still not appearing in Codex.

@Rosemary please include links to old encounters that originally had Sample IDs in Wildbook that are still not displaying in Codex so I can escalate this for investigation.

I wanted to follow up to let you know that the issue with Age and Behavior requiring data before you safe has been fixed. You should be able to save your encounters without having to add a number for age or the behavior observed. Thanks for your patience while we worked for fix this.