Zebra Summer Project Support Thread

Hey everyone!
As part of the support for the summer project for zebra.wildbook.org, we’re putting together this thread here on the forums. This is a place for anyone involved to ask questions to those of us who have the context of what you’re working on.

When asking your question, if you can, provide the following information:

  • What is the entire URL out of the browser, exactly where the error occurred?

  • Can you describe what the issue is you’re experiencing?

  • Can you provide steps on how to reproduce what you’re experiencing?

Hey Tanya,
I am having trouble entering “none” for the “rain” labeled keyword for the grevi zebras. It works when when I try to enter any other value such as “medium” or “heavy” but not for “none”.


Hey Eve,
There seemed to be some processing going on in the background with all of the “none” values. I’ve updated them, so now “rain” has the value “no rain”, and that works.

It works perfectly! Thank you for your super quick response!

1 Like

Hi Tanya,
Sorry to bother you again so soon.
I’m having another problem with the dropdown for the labeled keyword.

When I have more than three photos in my gallery, I have not been unable to add more than 4 keywords. The “add new keyword” box from the photo underneath blocks me from using the dropdown.


Thank you for your help,

Hey Eve,
That’s a problem I can’t workaround :frowning: We’re going to have to put some effort into fixing that, and I’m not sure what you can do in the meantime. Mark off as far as you get on each picture? Hopefully we’ll have this fixed asap so you don’t have a big backlog to get through. Tracking issue though WB-634

Thanks for let me know!
I really appreciate your help!:smiley:

Additionally, a tiny bug occurred when you changed the dropdown menu for options for “none”.

These keyword used to say “sun:full” and “wind: medium”, but after the dropdown was changed, they only say “full” or “medium”. Which would be confusing because in theory “medium” could be medium sun or medium wind. I changed the keyword tags back on the photos I had already done, but I wanted to let you know what happened.

Thanks again and have a good weekend,

Hey Eve,
Can you verify you’re using the labeled keyword dropdown (there’s labeled keywords and regular keywords)? I just checked for those keywords, and I’m getting the labels displayed.

This was only a problem for the labeled keywords I entered before you removed the “none” options. Only the rain, wind, and sun keywords I had already I entered went from labeled to regular. To fix it I just deleted the regular keywords and re-added the labeled one. I don’t think this is going to be an issue unless we change any of the labeled keyword options, but I wanted to let you know what happened.
Thanks again,

1 Like

Ah! Yea, that is expected when we have to make a change to existing keywords because of how we have to make adjustments in the database after the initial change. Deleting and reassigning is exactly what we recommend, so I think we’re all good on this issue at least. :slight_smile:

1 Like

Hi! I hope you are doing well! I have another question about the labeled keywords, specifically the “enter new” box.

To save time, I have been copy and pasting the relevant keywords into the “enter new tab”, making sure to copy exactly what the label keyword would look like if I used the dropdown menu.

For example, I have been entering “grass_species_3: Cynodon dactylon”. NOT simply entering “Cynodon dactylon”.

The result of using the dropdown labeled keyword and my copy and paste method looks the same from the user perspective, but I wanted to make sure that it also functions the same from the database/code perspective.


Do you think this difference in method will cause difficulty later on when we are trying to sort and analyze this data later on (as long as we are consistent with what we put in the “enter now” keyword entry)?

Thanks for your help,

It will cause some issues later on. The “enter new” is for keywords, not labelled keywords, which means that they will be stored in a different place in the database, which means that there will be inconsistent results in any analysis done on the data.

1 Like

Hey Tanya,
I hope you had a good weekend!
I am having an issue with the matching part of the site.
I had to delete and reupload this photo (I accidentally uploaded a version with check mark on it).

Now, wildbook isn’t letting me match this reuploaded photo. I keep getting this error that says “there was an error parsing results for task bf347c54-a8cf-4d07-a75e-51021de598d3”.

I tried reloading the website several times, and I restarted safari but I keep getting this error message.

Thank you for your help,

@ercooke, thanks, hope you did too! Can you send me the url for the encounter? I’ll get it cleaned up.

Thank you!

This is the link to the one had to reupload:

Also, this one is producing the same error even though I only uploaded it once

Okay, this should be resolved soon. Let me explain what’s happening and what to look for.

What happened: Sometimes an image does not successfully run detection. The image will not have a dotted box around the animal. If an animal hasn’t been detected, then we obviously can’t run ID.

How to fix this: We have a manual annotation tool, which can be accessed on a given image using the menu in the bottom right corner. I’m not sure if this is something you and the other students are encouraged to do though, so I would confirm with @AndyGersick.
Once you create an annotation and label the viewpoint and species, click save. Then return to the encounter and click “Start Another Match”. This will run ID on the annotation you just created.

1 Like

Thank you for your help on my previous inquiry!

I have found that on average it takes the matching software 88 seconds (range: 80 to 110 seconds) to find 4 matches from a photo with only one zebra in it.

And I have found that on average the software takes 128 seconds (range: 96 to 201 seconds) to find 4 matches from a photo with 2 or more zebras in it.

Is this amount of time to be expected given the number of zebras that the system is matching against?

Also, as I add more zebras to database the amount of time it takes to match increases, is that also to be expected?


Hi Tanya,

My issue is similar to Eve’s problem regarding the match results. Whenever I try to match a picture of a zebra, it says, “Attempting to fetch results” and eventually says, “Gave up trying to fetch results Refresh page to keep waiting.”

Here is the link: Wildbook for Zebras

Thanks for your help!

Hi Tanya!

Similarly to Safa, I was waiting for a zebra to match earlier this morning and it took 15 minutes of waiting before giving me an “attempting to fetch results” page that did not then translate to any zebra matches.

I have also been trying to keep track of the timing of matches more generally, and most of mine prior to this morning’s session have taken in the 30 to 180 second range with most requiring at least a minute. It seems to take less time for the first one in a session then after that become slower. I haven’t done enough matching yet though to know if this is a consistent pattern.

Thanks so much,


^ here’s a link to one of the pages where i got “attempting to fetch results”